Closed Bug 1014604 Opened 7 years ago Closed 7 years ago

Expose mozPhoneNumberService to privileged apps

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1021594

People

(Reporter: ferjm, Unassigned)

References

Details

Since we are going to be using the MSISDN as an ID for Loop we need to have access to mozPhoneNumberService to generate the internationalized version of a user phone number as this is the format stored in the server side.
Actually, we also need to expose https://mxr.mozilla.org/mozilla-central/source/dom/phonenumberutils/PhoneNumberUtils.jsm#129

Paul, Jonas, do you think that it is possible to add that function to the API and expose it to privileged apps?

FWIW the API is https://mxr.mozilla.org/mozilla-central/source/dom/webidl/PhoneNumberService.webidl
Flags: needinfo?(ptheriault)
Flags: needinfo?(jonas)
What does the function do, and why is it needed? I.e. how do you expect webpages to use it?
Flags: needinfo?(jonas)
I think this bug is a duplicate / very close to Bug 938265
Actually, we don't need this any more. The MobileID API makes sure that the verified phone number is provided in international format, so as long as Loop uses this API to get the user's phone number for the registration process we are good.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(ptheriault)
Resolution: --- → WONTFIX
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: mobileid
You need to log in before you can comment on or make changes to this bug.