Closed Bug 1014654 Opened 6 years ago Closed 6 years ago

Handle empty regions in SimplifyOutwardByArea()

Categories

(Core :: Graphics, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla32
Tracking Status
firefox31 --- fixed
firefox32 --- fixed

People

(Reporter: jrmuizel, Assigned: jrmuizel)

Details

(Whiteboard: [qa-] )

Attachments

(1 file)

No description provided.
https://hg.mozilla.org/mozilla-central/rev/cf80eda66bde
Assignee: nobody → jmuizelaar
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla32
[Approval Request Comment]
Bug caused by (feature/regressing bug #): 945079
User impact if declined: Crashes
Testing completed (on m-c, etc.): on m-c for a long time
Risk to taking this patch (and alternatives if risky): basically 0
Attachment #8435933 - Flags: approval-mozilla-aurora?
Attachment #8435933 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Jeff, just curious, is there a particular crash or type or crash this addresses? Thanks!
Flags: needinfo?(jmuizelaar)
Flags: in-testsuite+
Whiteboard: [qa-]
Yes, any crashes inside SimplifyOutwardByArea. However, the should be covered now.
Flags: needinfo?(jmuizelaar)
You need to log in before you can comment on or make changes to this bug.