--enable-trace-malloc needs to disable symbol-removal passes

RESOLVED FIXED

Status

SeaMonkey
Build Config
RESOLVED FIXED
17 years ago
14 years ago

People

(Reporter: shaver, Assigned: shaver)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

We need to turn off the version script and the .dynstr GC when we're looking to
use trace-malloc, or we just get noise in the logs.

Patch coming right up.
Created attachment 50640 [details] [diff] [review]
Make --enable-trace-malloc turn off MOZ_COMPONENTS_VERSION_SCRIPT_LDFLAGS and USE_ELF_DYNSTR_GC

Comment 2

17 years ago
Comment on attachment 50640 [details] [diff] [review]
Make --enable-trace-malloc turn off MOZ_COMPONENTS_VERSION_SCRIPT_LDFLAGS and USE_ELF_DYNSTR_GC

r=waterson
Attachment #50640 - Flags: review+

Comment 3

17 years ago
*** Bug 101441 has been marked as a duplicate of this bug. ***

Comment 4

17 years ago
r=cls
Checked in, thanks.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.