Closed Bug 1014704 Opened 5 years ago Closed 5 years ago

[B2G][Tarako][E.me] Everything.me apps are not adding to homescreen when selecting 'Add to Homescreen'

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3T+, b2g-v1.3 unaffected, b2g-v1.3T verified)

VERIFIED FIXED
blocking-b2g 1.3T+
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.3T --- verified

People

(Reporter: jschmitt, Assigned: fabrice)

References

Details

(Keywords: regression, smoketest)

Attachments

(2 files)

Attached file log.txt
Description:
The E.me apps are not being added to the homescreen.

Repro Steps:
1) Update a Tarako to BuildID: 20140522014001
2) Connect to Wifi
3) Search 'Social' in the E.me search
4) Select 'Facebook'
5) Once loaded, tap the up arrow icon and select the 'Star' icon
6) Select 'Add to Homescreen'
7) Go back to the Homescreen

Actual:
Facebook is not added to the homescreen.

Expected:
Facebook is added to the Homescreen.

1.3 Environmental Variables:
Device: Tarako 1.3
BuildID: 20140522014001
Gaia: 6ad553e9db091f7400069a4551941cf4249c0544
Gecko: d95a3af17d6e
Version: 28.1
Firmware Version: sp6821a-gonk-4.0-5-12

Notes:
Repro frequency: 100%
See attached: logcat
Issue does NOT repro on 1.3 Buri.

1.3 Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140522024002
Gaia: 0ce948e378cab7ed3db20231281dd7ca2eb99779
Gecko: a61b65a57289
Version: 28.0
Firmware Version: v1.2-device.cfg
QA Contact: pcheng
blocking-b2g: --- → 1.3T?
Adding to homescreen is not working from browser as well.

STR:
1. launch browser
2. go to news.google.com
3. select bookmark icon
4. tap on add to home screen

Expected: icon on homescreen
Actual: no icon on homescreen
looks like somehow the process got killed.
bad 7d1b3ebe681bab9db53bcddb01008a50b253a346
good f64d0237b49dab5eba5dc82b2a6d816e1e481f62


I believe it's Bug 1014272 as a regression; alive can you please take a look?
Flags: needinfo?(alive)
Thanks, Naoki, for pinpointing the cause. Let me know if any help is needed from me.
Keywords: qaurgent
blocking-b2g: 1.3T? → 1.3T+
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #4)
> bad 7d1b3ebe681bab9db53bcddb01008a50b253a346
> good f64d0237b49dab5eba5dc82b2a6d816e1e481f62
> 
> 
> I believe it's Bug 1014272 as a regression; alive can you please take a look?

That's correct. If you restart b2g you will find the icon on the homescreen actually...

What happens is that the homescreen triggers the "add to homescreen" activity, which is served by himself. We usually try to reuse the same process on tarako, *except in the parent*. We then start a new oop homescreen (to display the dialog that let you change the icon title), and fail to update the in-process homescreen.

That's annoying...
Blocks: 1014272
Hm, so after some more debugging, actually the system app triggers the activity which makes sense since the bookmarking is initiated by the window manager iframe wrapper. We then have a "parentApp == systemApp" and don't let the activity run in-process. Except that if we already decided that it was ok to run the homescreen in-process we should whitelist this case. Still not sure how to do that in a way that doesn't make me sad.
Alive, the issue there is that we were unconditionally running activity frames OOP, which is not correct when the activity provider runs in process. That patch fixes that by using BrowserConfigHelper to not duplicate code.

I haven't check if that part of the code has changed a lot on master, but we should fix it there too.
Assignee: nobody → fabrice
Attachment #8427437 - Flags: review?(alive)
Component: Gaia::Everything.me → Gaia::System
Comment on attachment 8427437 [details] [diff] [review]
activity-oop-or-not.patch

Review of attachment 8427437 [details] [diff] [review]:
-----------------------------------------------------------------

The part is removed in master. All inline activity is using BrowserConfigHelper
Attachment #8427437 - Flags: review?(alive) → review+
Flags: needinfo?(alive)
Landed on 1.3t as c8f6ba7aa9a694f5f691555a0d049f5630cdde3d
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Flags: needinfo?(yang.zhao)
See comment#10 ,already landed it on v1.3t.
Flags: needinfo?(yang.zhao)
(In reply to yang.zhao from comment #11)
> See comment#10 ,already landed it on v1.3t.

Is it fix wallpaper issue?
Verified fixed on latest 1.3T.

1.3 Environmental Variables:
Device: Tarako 1.3 MOZ
BuildID: 20140527014007
Gaia: c8f6ba7aa9a694f5f691555a0d049f5630cdde3d
Gecko: bde42427e332
Version: 28.1
Firmware Version: SP6821a-Gonk-4.0-5-12
Status: RESOLVED → VERIFIED
Depends on: 1016472
Depends on: 1017331
It caused monkey test home screen black and no ion issue. We have revert it by WIP patch on my side and run monkey test to verify.
You need to log in before you can comment on or make changes to this bug.