[Dialer] "Bamba" string displayed on Call Waiting button

VERIFIED FIXED in 2.0 S4 (20june)

Status

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: tchevalier, Assigned: stas)

Tracking

({regression})

unspecified
2.0 S4 (20june)
x86_64
Linux
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v1.4 unaffected, b2g-v2.0 verified, b2g-v2.1 verified)

Details

(Whiteboard: [2.0-flame-test-run-1])

Attachments

(4 attachments)

1. Call someone.
2. Someone call you

-> "Bamba" is displayed on the call waiting button.

I did a grep on gaia, can't find "Bamba". Weird bug :)
Whiteboard: [2.0-flame-test-run-1]
blocking-b2g: --- → 2.0?
Duplicate of this bug: 1019202
Ugly visual bug we cannot ship with :(, blocking.
blocking-b2g: 2.0? → 2.0+
The attached screenshot in 1019202 is the new design, reproducible in Flame with build 20140605160202.
https://bug1019202.bugzilla.mozilla.org/attachment.cgi?id=8432754

### Build Information
Device: Flame
Gaia      908f94fda04462001ece86e6b6c15ad8b05f7526
Gecko     https://hg.mozilla.org/mozilla-central/rev/5e8e9d864a4d
BuildID   20140605160202
Version   32.0a1
ro.build.version.incremental=94
ro.build.date=Tue May 20 09:29:20 CST 2014
Happened with master(en), not localized UI.
QA Contact: jharvey
Assignee: nobody → anthony
Target Milestone: --- → 2.0 S4 (20june)
We think it might be changing .innerHTML to .ariaLabel in the localisation files or something like that.
Just commenting that it seems a bug specific of Flame device. 
At least, I am not able to reproduce it with muy buri.
Hm, I can reproduce on Buri, with latest master.

And the funny part is that is displays a totally different string
(In reply to Anthony Ricaud (:rik) from comment #5)
> We think it might be changing .innerHTML to .ariaLabel in the localisation
> files or something like that.

just noticed that "Bamba" comes from Xhosa locale, here: http://mxr.mozilla.org/l10n-gaia/source/xh/apps/communications/dialer/dialer.properties#57
en-US and updated locales don't have that string anymore on master, they have hold.ariaLabel

xh still have "hold" on master, like sk (second screenshot you posted, "Podržať")
https://hg.mozilla.org/gaia-l10n/sk/file/default/apps/communications/dialer/dialer.properties#l58

Not sure what's going on, if that's a build or run-time issue.
B2G Inbound Regression Window

Last Working 
Environmental Variables:
Device: Buri
BuildID: 20140402123132
Gaia: 039037c16948c0985f6779886fac595b111979f4
Gecko: e7b7bdbffe2b
Version: 31.0a1
Firmware Version: v1.2-device.cfg

First Broken
Environmental Variables:
Device: Buri
BuildID: 20140402130133
Gaia: 208d70961b6e3f615b9195d9558157bf7b1fdd28
Gecko: ba30e8f5d6b4
Version: 31.0a1
Firmware Version: v1.2-device.cfg

Last Working Gaia First Broken Gecko: Issue does NOT reproduce
Gaia: 039037c16948c0985f6779886fac595b111979f4
Gecko: ba30e8f5d6b4

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: 208d70961b6e3f615b9195d9558157bf7b1fdd28
Gecko: e7b7bdbffe2b

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/039037c16948c0985f6779886fac595b111979f4...208d70961b6e3f615b9195d9558157bf7b1fdd28
QA Whiteboard: QAnalyst-Triage?
Flags: needinfo?(jmitchell)
QA Whiteboard: QAnalyst-Triage? → QAnalyst-Triage+
Flags: needinfo?(jmitchell)
Broken by Bug 923139. Can you fix this regression?
Blocks: 923139
Flags: needinfo?(yzenevich)
QA Whiteboard: QAnalyst-Triage+ → [QAnalyst-Triage+]
Looks like this is not the issue of a l10n bundle having an older hold=Hold string instead of hold.ariaLabel=Hold . It looks like a string from a wrong locale is somehow being loaded into markup.
Flags: needinfo?(yzenevich)
Per comment 9 and 12, this is not a dialer bug but an L10n one.

We can still help by changing the name of the hold attribute in the dialer code base if you need it.
Assignee: anthony → nobody
Component: Gaia::Dialer → Gaia::L10n
Stas, can you verify if that's possible that it's the inconsistency between entity and entity.ariaLabel between locales?
Flags: needinfo?(stas)
Sure, I'll have a look while you're on PTO, no worries.  Leaving the needinfo request for now.
Kevin: for the future reference. Please, f? me or stas on bugs like that. We want to take part in designing the interaction between web components and l10n.
wrong bug. sorry!
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
Posted patch PatchSplinter Review
Pull request:  https://github.com/mozilla-b2g/gaia/pull/20441

Travis: https://travis-ci.org/mozilla-b2g/gaia/builds/27404904
Try: https://tbpl.mozilla.org/?tree=Gaia-Try&rev=9a38e482e33c

The root cause of this is that during buildtime we use the same document object for all locales that we optimize for.  If language A has an old entity defined ('hold'), and language B does not (because it's now called hold.ariaLabel), we don't erase the textContent of the element, and the translation from language A remains.

The fix is easy, however.  We actually don't need to pretranslate the HTML into anything else than the default language.  It's the only one that is saved into the zip anyways.

This patch keeps the getDictionary part of the build time optimization (concatenation into a single JSON file and inlining some strings in <script> tags in HTML), but only actually pretranslates the HTML into the default language.
Assignee: nobody → stas
Status: NEW → ASSIGNED
Attachment #8439197 - Flags: review?(gandalf)
Flags: needinfo?(stas)
Comment on attachment 8439197 [details] [diff] [review]
Patch

Review of attachment 8439197 [details] [diff] [review]:
-----------------------------------------------------------------

Sweet. That will make blacklisting from pretranslation easier. r+
Attachment #8439197 - Flags: review?(gandalf) → review+
Duplicate of this bug: 1024424
Tested and working
Hamachi
2.1
Gecko-a3c4c53
Gaia-5f9f64a

Hamachi
2.0
Gecko-3bfc06b
Gaia-5e14503
Status: RESOLVED → VERIFIED
This issue has been verified successfully on Flame2.0&2.1.

Reproducing rate: 0/5
See attachment: Verify_Flame_Calling.mp4

Flame 2.0 build version:
Gaia-Rev        8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/c756bd8bf3c3
Build-ID        20141127000203
Version         32.0

Flame2.1 build version:
Gaia-Rev        5372b675e018b6aac97d95ff5db8d4bd16addb9b
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/f34377ae402b
Build-ID        20141127001201
Version         34.0
You need to log in before you can comment on or make changes to this bug.