Closed Bug 1015334 Opened 5 years ago Closed 5 years ago

[dev] New map input interface tweaks

Categories

(Participation Infrastructure :: Phonebook, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: hoosteeno, Assigned: wbowling)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

This bug will capture problems and suggested solutions for the map input interface, which has landed on dev (bug 976330). 

* If you set your location to the USA without state/city, you automatically get "Belpre, Kansas, United States" as your location. You should get "United States". 

* It's not obvious how to set your location. There seem to be 3 ways: Search using the little search icon, drag the pin, or type in a lat/lng. Suggestions for improving this interface:
  ** Make the search input box a permanent feature rather than hidden; make it more prominent; move it outside the map; and add instructions that explain the specificity that is required and optional ("Country is required. State/Region and City are optional.")
  ** Don't allow people to drag the point. Without labels on the map it's difficult to use. Or add labels to the map.
  ** If people use the lat/lng inputs, refresh the map and geolocated strings on unfocus. Or hide the lat/lng inputs. I think we originally agreed to do the latter.
(In reply to Justin Crawford [:hoosteeno] from comment #0)
> Suggestions for improving this interface:
>   ** Make the search input box a permanent feature rather than hidden; make
> it more prominent; move it outside the map; and add instructions that
> explain the specificity that is required and optional ("Country is required.
> State/Region and City are optional.")

Agreed. I think the Search box is going to be the easiest and best way for someone to input their location.

>   ** Don't allow people to drag the point. Without labels on the map it's
> difficult to use. Or add labels to the map.

Makes sense. If we focus on search, then dragging the point is not needed.

>   ** If people use the lat/lng inputs, refresh the map and geolocated
> strings on unfocus. Or hide the lat/lng inputs. I think we originally agreed
> to do the latter.

I think it is best to hide the lat/lng inputs. Since we only need to get as specific as the city, there is no need to show those.

Great suggestions, Justin!
Perhaps arrogantly, Dan and I thought it was easier to require that folks put in a location that had a real lat/lng point and then use permissions to limit what other people could see. It was indeed easier for us, but harder to understand for the end user like you point out.

Moving the search box outside of the map is a little more difficult. Mapbox puts the geooding search button where it wants to. Again, easier for us, not not necessarily for the end user.

Don't allow people to drag the point, eh? Well... how about we leave the feature there but *don't count it*? I'll focus first on how we can make the searching functionality better.

Hiding the lat/lng fields seems smart enough.

>> If you set your location to the USA without state/city, you automatically get "Belpre, Kansas, United States" as your location. You should get "United States".

This only occurs if you're dragging the marker which makes sense. Typing "USA" or "United States" into search gets you the result you want.
Attached image new_search_results.png
I took a try at something new today using the geocoding web service instead of the geocoder that's built in to the JS api. Results come back as a list of inline-blocks you could click on.

(Orange is most definitely not the final color. It's just easy to see, so i use it lot when i'm making prototypes.)

The area that these results goes in to is scrollable though it's not abundantly obvious yet that there are more results further down. I'm going to add hint shadows like these: http://lea.verou.me/2012/04/background-attachment-local/
:wbowling, I think the new search interface looks like a great improvement, once you work out how to display a list of possible matches. Nice!

* I would suggest getting rid of the search in the map; it's too many ways to search. 
* Maybe a search button? And maybe the "locate me" button is next to the search button?
Assignee: nobody → wbowling
Status: NEW → ASSIGNED
Duplicate of this bug: 1015966
Commits pushed to master at https://github.com/mozilla/mozillians

https://github.com/mozilla/mozillians/commit/7279aa97688bb841c095735145abee6fef13169b
[Bug 1015334] Workaround mapbox multiple-city-with-same-name issue, and cosmetic/l10n tweaks.

https://github.com/mozilla/mozillians/commit/e51921403e0561b5aedd99247b3246daf66106ae
Merge pull request #962 from Sancus/geofixes

[Bug 1015334] Workaround mapbox multiple-city-with-same-name issue, and cosmetic/l10n tweaks.
Commits pushed to master at https://github.com/mozilla/mozillians

https://github.com/mozilla/mozillians/commit/017fcfbd5051fe6a1658805e963ca3a11897951f
[Bug 1015334] Many improvements to location editing

Including, but not limited to:
* Convert js whitespace to tabs.
* Fix js breaking when profile has no lat/lng.
* Search result display improved.
* Shadow hints applied.
* Marker moves after searching.
* Fit map search to mobile layouts, and improved aesthetics.
* Pressing enter on search takes the first result.
* Hide lat/lng fields on edit profile page.
* Remove unused parts of profile edit mapbox code.
* Add pacifier for search while ajax results are pending.
* Displaying bounds is optional and off by default.
* Tile layer uses mozilla.org tile set.
* Improve zooming substantially (any region which crosses the prime meridian will freak out, but this is map box’s fault for providing bad bounding boxes, not ours)
* Don't display box when there are no search results.
* Fix loader gif race condition.
* Dragging pin auto-centers on city.
* Make entry of region/city optional.
* Require entering country at minimum.
* Handle display if lat/lng is missing on profile.

Much credit to @wraybowling for UI and JS.

https://github.com/mozilla/mozillians/commit/b3d91a09b0cbf31e66ebaf4c739fe1ceaecf2200
Merge pull request #968 from Sancus/1015334-new-map-tweaks

[Bug 1015334] Many improvements to location editing
Fixed by the above commit.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Bumping to verified - we shipped! Lot's of hurrah to the team for a finished product.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.