After selecting text with ALT - Mouse Drag, CTRL-C doesn't copy to clipboard

RESOLVED WORKSFORME

Status

()

Core
Event Handling
RESOLVED WORKSFORME
17 years ago
12 years ago

People

(Reporter: Aleksander Adamowski, Unassigned)

Tracking

Trunk
Future
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Build ID: 2001092403
Introduction:
ALT key has a special meaning when used in conjuncion with mouse dragging over
links: it causes Mozilla to select portions of link text instead of starting a
Drag And Drop opertaion on a link. This way, one can select part of a link's
text and copy it to clipboard. However, it is only possible to copy the text
through Edit->Copy. CTRL-C binding doesn't work.

Steps to reproduce:
1. Load any page with a text hyperlink
2. Press ALT
3. While holding ALT press the left mouse button over the middle of the link
4. While holding ALT and the left mouse button move the mouse right or left to
select a portion of hyperlink's text
5. Release the left mouse button, then release ALT key.
6. Press CTRL-C.

Expected behaviour:
Selected text is copied to the clipboard

Observed behaviour:
Selected text is _not_ copied to the clipboard. Contents of the clipboard remain
intact.
When using Edit->Copy , the expected behaviour occurs.

BTW, I observed that when ALT - clicking on links on
http://office.altkom.com.pl/olo/index.html Mozilla behaves very strange.
Instead of ignoring the event of clicking on a link, Mozilla pauses for a few
seconds, then proceeds through the link as if it was clicked normally.
Does that qualify as a separate bug?

Comment 1

16 years ago
this isnt a selection bug. something funny is happening with the alt key. 
recommending future, but will let the events owner decide that.
Assignee: mjudge → joki
Component: Selection → Event Handling
QA Contact: tpreston → madhur

Comment 2

16 years ago
It's because the ALT key is activating the menu when it gets released.  That
event needs to be cancelled if the mouse is down any time between pressing and
releasing ALT.  That appears to be the normal Windows behaviour.  I just tested
in Notepad.
(Reporter)

Comment 3

16 years ago
burpmaster: What appears to be the normal Windows behaviour?
Cancelling (as you described it should be) or not cancelling (as we observed in
Mozilla) ALT events if the mouse is down between ALT press and release?

I'm on Windows 2000, in the Notepad and MS Word it seems that mouse event
cancels ALT events and menu isn't opened, so CTRL-C works. Is it what you saw in
Notepad on your system?

Comment 4

16 years ago
I guess I was a little bit unclear.  Yes, that is what I saw when testing with
Notepad: a mousedown after an ALT-down cancels the menu opening on ALT-up.

Comment 5

16 years ago
dup of something I had/have or gave to pink or hyatt
Assignee: joki → saari

Comment 6

16 years ago
Sounds like the Alt key listener on xpmenus needs to listen for mouse events and
deactivate itself, OR, the alt key listener needs to pass events through that it
isn't processing, like the ctrl+c for the copy.
Assignee: saari → hyatt

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Updated

16 years ago
QA Contact: madhur → rakeshmishra

Updated

15 years ago
QA Contact: rakeshmishra → trix

Comment 7

14 years ago
WFM with Mozilla 1.7a 2004011508 under WinNT4.

Comment 8

14 years ago
But doesn't WFM with Mozilla 1.6 (20040113) on Windows 98SE.

Comment 9

14 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7a) Gecko/20040207
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 10

14 years ago
Reopening: it still doesn't WFM in Mozilla/5.0 (Windows; U; Win98; en-US;
rv:1.7a) Gecko/20040208. Perhaps it's now fixed in WinNT/2k/XP but not in Win9x?

In fact, I've become so used to hitting Ctrl+Insert twice (to workaround this
bug), that I do it everywhere and Office gives me a hard time with its
multi-clipboard. :-) (And no, it's not because I use Ctrl+Insert instead of
Ctrl+C - I just tried both, the problem is still there.)
Status: RESOLVED → REOPENED
OS: Windows 2000 → Windows 98
Resolution: WORKSFORME → ---

Comment 11

14 years ago
This is still a problem with 2004021709 Seamonkey build on winXP.
Assignee: hyatt → events
Status: REOPENED → NEW
QA Contact: trix → ian

Comment 12

14 years ago
(In reply to comment #7)
> WFM with Mozilla 1.7a 2004011508 under WinNT4.

Sorry, my comment was wrong. It doesn't WFM. First Ctrl+C leads only to a error
beep and on the second Ctrl+C the selection is copied. Tested with 1.7a on WinNT4.

Updated

13 years ago
Blocks: 96645

Updated

13 years ago
Blocks: 133439

Updated

13 years ago
No longer blocks: 133439

Updated

13 years ago
No longer blocks: 96645

Comment 13

13 years ago
See 133439, 96645, 278927, 153145, 252084, 196897, 101539

Comment 14

12 years ago
(In reply to comment #13)
> See bug 133439, bug 96645, bug 278927, bug 153145, bug 252084, bug 196897, bug 101539

so this is windows only?

fails - Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5  *and*  Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051219 SeaMonkey/1.5a

Comment 15

12 years ago
It's not Windows only.  In my Linux build "copy" fails every time ctrl-C is used in the browser window itself (i.e. ctrl-C works in the location and search bars but not on the page itself.) Right click and Edit menu always do the trick.

Broken in 
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060505 Minefield/3.0a1

Comment 16

12 years ago
Well this WFM now, but I can't find what checkin fixed it.  I'm fairly certain that it was fixed in today's build, and that yesterday's was still broken.

WFM on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060510 Minefield/3.0a1

Comment 17

12 years ago
also WSM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Status: NEW → RESOLVED
Last Resolved: 14 years ago12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.