Browser Crash [Talkback ID below]

RESOLVED DUPLICATE of bug 101177

Status

SeaMonkey
General
--
critical
RESOLVED DUPLICATE of bug 101177
16 years ago
13 years ago

People

(Reporter: Ashley Bischoff (blog at handcoding.com), Assigned: asa)

Tracking

({crash})

Trunk
x86
Windows 2000
crash

Firefox Tracking Flags

(Not tracked)

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4+)
Gecko/20010922
BuildID:    2001092208

Mozilla just crashed. I just clicked on a link in my mail app, and Mozilla died
(I'm not certain that the click-in-mail-app is the cause).

Reproducible: Didn't try
Steps to Reproduce:
1. I wish I knew what steps I used. 
2. It may have something to do with Windows Integration.
3.

Actual Results:  Crash

Expected Results:  No crash ;)

Talkback ID: TB35859136E. 

Asa: I apologise in advance for filing this in Browser:General, but I really
have no idea which component is applicable ;).

Filing as "critical", as that's described as "Mozilla crashes, hangs, leaks
memory, or causes you to lose data".

Updated

16 years ago
Keywords: crash
(Assignee)

Comment 1

16 years ago
Incident ID 35859136
Stack Signature nsDocument::SetTitle 553b95cc
Bug ID
Trigger Time 2001-09-25 08:37:59
Email Address alex@spamcop.net
User Comments I have no idea.
Build ID 2001092210
Product ID MozillaTrunk
Platform ID Win32
Trigger Reason Access violation
Stack Trace
nsDocument::SetTitle
[d:\builds\seamonkey\mozilla\content\base\src\nsDocument.cpp, line 2376]
nsHTMLDocument::SetTitle
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLDocument.cpp, line 900]
HTMLContentSink::DidBuildModel
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLContentSink.cpp,
line 2680]
CNavDTD::DidBuildModel [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp,
line 655]
nsParser::DidBuildModel
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 1410]
nsParser::ResumeParse [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp,
line 1938]
nsParser::OnStopRequest
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 2533]
nsDocumentOpenInfo::OnStopRequest
[d:\builds\seamonkey\mozilla\uriloader\base\nsURILoader.cpp, line 257]
nsStreamListenerTee::OnStopRequest
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsStreamListenerTee.cpp, line 25]
nsHttpChannel::OnStopRequest
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHttpChannel.cpp, line 2220]
nsOnStopRequestEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsRequestObserverProxy.cpp, line 162]
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 591]
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 524]
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line
1072] 

Comment 2

16 years ago
Asa, I was doing pre-screening on this bug. I think that this one seems to be
dupe of 101177, which has just been fixed.
Cf.
http://bonsai.mozilla.org/cvsquery.cgi?branch=HEAD&file=mozilla/content/base/src/nsDocument.cpp&date=week

We see that the crash happens both in nsDocument::SetTitle lines 2375 and 2376
(in older versions of the file).
The bug was reported with the build from the 22nd, while the bug was corrected
on the 23rd.
(Assignee)

Comment 3

16 years ago
Jerome, great work! 
Alex, if this isn't fixed please reopen.

*** This bug has been marked as a duplicate of 101177 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.