Closed Bug 1015402 Opened 8 years ago Closed 8 years ago

[B2G][2.0][VerticalHomescreen] The icons of downloaded apps are not displayed.

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set
blocker

Tracking

(b2g-v2.0 fixed)

VERIFIED FIXED
2.0 S3 (6june)
Tracking Status
b2g-v2.0 --- fixed

People

(Reporter: ychung, Assigned: crdlc)

References

Details

(Keywords: regression, Whiteboard: [systemsfe])

Attachments

(3 files)

Attached image MissingIcons.png
Description: 
Some of the apps' icons are not shown on the homescreen after donwloaded on the vertical homescreen.

Repro Steps:
1) Update a Flame to BuildID: 20140523073020.
2) Settings > Homescreen > Vertical > Change.
3) Select the home button, and open the Marketplace app.
4) Install multiple apps (ex. LINE, CutTheRope, Whatsap, Slice Fruits, Aviary, etc.)
5) Return to homescreen and observed the downloaded apps.

Actual:
The icons of the apps are not displayed.

Expected:
All icons of the apps are displayed correctly.

Note:
When the homescreen is switched to the Homescreen view, the icons are properly displayed. When switched back to the vertical view, the icons are properly displayed as well.


2.0 Environmental Variables:
Device: Flame 2.0Eng
BuildID: 20140523073020
Gaia: e83bd91c8f7c66f95d55cb741299e12bc8f7b429
Gecko: 681c5668d881
Version: 32.0a1
Firmware Version: v10G-2

Keywords: Vertical Homescreen, icon, Marketplace apps

Repro frequency: 100%
Link to failed test case: N/A
See attached: screenshot, logcat
This issue also occurs on Open C 2.0Eng:

2.0 Environmental Variables:
Device: Open_C 2.0
BuildID: 20140523073020
Gaia: e83bd91c8f7c66f95d55cb741299e12bc8f7b429
Gecko: 681c5668d881
Version: 32.0a1
Firmware Version: P821A10V1.0.0B06_LOG_DL
Major regression since the last homescreen.
Severity: normal → blocker
Keywords: regression
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
Whiteboard: systemfe → [systemsfe]
Target Milestone: --- → 2.0 S3 (6june)
Attached file Github pull request
Thanks for your time Kevin
Attachment #8428671 - Flags: review?(kgrandon)
Comment on attachment 8428671 [details]
Github pull request

Works like a charm. Thank you!
Attachment #8428671 - Flags: review?(kgrandon) → review+
Landed: https://github.com/mozilla-b2g/gaia/commit/7fe4600af822a2da87df47d6b3e224c18e42b5c7
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.