Crashes when I try to copy long sequences in query fields

VERIFIED DUPLICATE of bug 78980

Status

()

Core
Editor
--
critical
VERIFIED DUPLICATE of bug 78980
17 years ago
17 years ago

People

(Reporter: Paolo Guarnieri, Assigned: kinmoz)

Tracking

({crash, stackwanted, testcase})

Trunk
x86
Windows 98
crash, stackwanted, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.4) Gecko/20010913
BuildID:    2001091303

I use genomic databeses and I always cut-paste Long dna sequences in query
fields and if the sequence(nothing else than txt!) is too long(sorry I didn't
calculete the exact lenght) mozilla crashes.

Reproducible: Always
Steps to Reproduce:
1.Get a long text(today the sequence was about 488K)
2.connect for example here:
http://www.ncbi.nlm.nih.gov/blast/Blast.cgi?CMD=Web&LAYOUT=TwoWindows&AUTO_FORMAT=Semiauto&ALIGNMENTS=50&ALIGNMENT_VIEW=Pairwise&CLIENT=web&DATABASE=nr&DESCRIPTIONS=100&ENTREZ_QUERY=(none)&EXPECT=10&FILTER=L&FORMAT_OBJECT=Alignment&FORMAT_TYPE=HTML&HITLIST_SIZE=100&NCBI_GI=on&PAGE=Nucleotides&PROGRAM=blastn&SERVICE=plain&SET_DEFAULTS.x=34&SET_DEFAULTS.y=8&SHOW_OVERVIEW=on&END_OF_HTTPGET=Yes
3.cutpast a long text(doesn't care if a dna sequence or something else)
4.BOOM!

Actual Results:  mozilla closes without any other problem on the system.

Expected Results:  Accepted the entire sequence, like the so hated IE!
editor-core?

reassign as needed...
Assignee: pchen → kin
Component: XP Apps → Editor: Core
Keywords: crash
QA Contact: sairuh → sujay
Reporter: Please try a talkback-enabled build:
http://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-win32-talkback.zip
(as always, be sure to delete your old Mozilla directory before installing the
new one)

Then, if you can get a Talkback ID after the crash, please post it here.
Keywords: stackwanted

Comment 3

17 years ago
Confirming.

Crash on 2001092503 win98.  Crash does not invoke Talkback ...

MOZILLA caused a general protection fault
in module GDI.EXE at 0027:000005de.
Registers:
EAX=00001001 CS=05e7 EIP=000005de EFLGS=00010206
EBX=00000020 SS=129f ESP=d0f1a2e8 EBP=0000a316
ECX=00008ac6 DS=4246 ESI=0000000a FS=1a1e
EDX=00000a66 ES=1a1e EDI=0000004a GS=1826
Bytes at CS:EIP:
66 83 3c 47 00 0f 84 24 01 00 00 66 8b 04 42 03 
Stack dump:
000011d4 00001594 00000627 00000000 11d40627 00000000 00000006 00000000 1400140f
00000a66 182611d4 a3cc0027 05df062c 1594a38a 00001a1e 8aca0000

To reproduce:
1) Visit any site with a text input
2) Copy-Paste the attached file (crashpaste.txt)
   Paste should work, no crash (does not display properly tho)
3) Add 1 char to the field
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

17 years ago
Created attachment 51476 [details]
32769-character text file

Comment 5

17 years ago
Adding myself to CC, adding testcase keyword.

Note that although this testcase is consistent for me, it has been reported that
the required length to induce a crash varies.

Comment 6

17 years ago
Ok, really adding testcase this time ...
Keywords: testcase

Comment 7

17 years ago
My apologies for the bug spam .... I'm just dumb today.

This might also be a dup of 86262.

*** This bug has been marked as a duplicate of 78980 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 8

17 years ago
Verified Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.