Closed Bug 1015439 Opened 7 years ago Closed 7 years ago

Disable unknown-properties-flagging when doing SetElem on small objects

Categories

(Core :: JavaScript Engine: JIT, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla32

People

(Reporter: djvj, Assigned: djvj)

Details

Attachments

(1 file)

Currently, if a Propertyname SetElem operation occurs on an non-singleton object with 8 or more properties, then the object is immediately marked as unknownProperties.

I noticed this to be deoptimizing and losing type info on a LOT of objects being used in wild web code, since that sort of code often uses property-copy methods to add properties to instances.

This limit should be a lot higher.
Changes the deopt threshold from 8 to 128.  Ran it on sunpsider and octane, no perf regressions.
Attachment #8428034 - Flags: review?(bhackett1024)
Attachment #8428034 - Flags: review?(bhackett1024) → review+
https://hg.mozilla.org/mozilla-central/rev/e99116791b54
Assignee: nobody → kvijayan
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla32
You need to log in before you can comment on or make changes to this bug.