drag and drop of multiple selected messages not possible

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
P2
normal
VERIFIED WORKSFORME
17 years ago
13 years ago

People

(Reporter: Christof Barth, Assigned: Navin Gupta)

Tracking

Trunk
mozilla1.0
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
in 0.9.4 you can select several messages, but you can't drag them onto folders.

Steps to reproduce:
1. select several messages in the mail window using ctrl key
2. try to drag them onto a folder 

You will see that selection is reduced to only one message which can be dragged.
Expected behavior: drag and drop multiple messages at one time

Updated

17 years ago
QA Contact: esther → sheelar

Comment 1

17 years ago
Christof, can you provide screenshots that illustrate this issue?
(Reporter)

Comment 2

17 years ago
Created attachment 50754 [details]
requested illustration, see following posting for details
(Reporter)

Comment 3

17 years ago
to do the just attached screenshot I checked the behavior again and found that
it seems to be two issues now. 

1) You can drag several messages if you grab them in the subject column or one
thereafter. Although if you drag them onto folders they won't be moved. If you
switch to threaded view same thing happens if you try to drag and drop a thread
onto folders: the thread won't be moved into the desired folder.

2) Trying to grab multiple selected messages in the first column (indicated by
arrow 1) changes the selection to only one single message. In regard to the
screenshot if I grab it in the last selected line only this single message will
be dragged.

Comment 4

17 years ago
Reporter,
Can you give the build id that you are using? Have you been able to reproduce
this every time?
(Reporter)

Comment 5

17 years ago
I can reproduce this every time using 0.9.4 as well as the current nightly
Gecko/2001092703.

Also dragging several messages in collapsed threaded mode moves only one message
at a time.

Comment 6

17 years ago
Reporter,
confirming that we cannot DND multiple messages when you ctrl select and try to 
move it from the subject column. (2001-10-31-06 win98)

Reporter,
In your last comments:  "Also dragging several messages in collapsed threaded 
mode moves only one message at a time."

This is a different issue than what reported initially. We have a know bug on 
this issue

But I see that when you ctrl select multiple messages and try to drag and drop 
from the subject column the selection changes to a single message.  So we will 
keep this bug for the #2 comments from 2001-09-25 14:58
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

17 years ago
dup of bug 48912?

Comment 8

16 years ago
*** Bug 109638 has been marked as a duplicate of this bug. ***

Comment 9

16 years ago
Still a problem on build 2001-12-14-06. Cannot drag and drop multiple messages 
from the subject column
Assignee: sspitzer → naving

Comment 10

16 years ago
Same problem with using XFree86 on Win2K with FreeBSD build:
Mozilla 0.9.7
Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:0.9.7) Gecko/20020218
(Assignee)

Comment 11

16 years ago
I was never able to do this.
Keywords: nsbeta1

Comment 12

16 years ago
Discussed in 2/26 bug meeting with Mktg Engineering and PjM.  Decision was to
nsbeta1 plus make P2, and assign to 1.0.
Keywords: nsbeta1 → nsbeta1+
Priority: -- → P2
Target Milestone: --- → mozilla1.0

Comment 13

16 years ago
Using build 20020225 one winxp, drag n drop mutiple select messages works in
these cases:
Select mutiple messages, Ctrl+ drag (within the Subject column) from one folder
to the another in same IMAP account = copy of messages not a move of
messages=correct behavior
Select multiple messages, (within the Subject column) hold mouse and drag from
one folder to another in same IMAP account = move of messages not a copy =
correct behavior.
Sort by Thread select the the thread icon, which multiple selects the threads,
Ctrl+drag from one folder to another in same IMAP account copies all the threads
to to the destination folder =correct behavior
Sort by Thread select the the thread icon, which multiple selects the threads,
drag from one folder to another in same IMAP account moves all the threads to 
the destination folder =correct behavior
So far this is correct behavior.  I will try more scenarios, but if anyone of
you see that I'm not testing the bug, please let me know the specific steps.

Comment 14

16 years ago
Update, more testing:
I did a non-continuous multiple select and then a Ctrl+drag to another IMAP
folder within the same IMAP account = all messages were copied to the
destination folder=correct behavior
I did a non-continuous multiple select and the click drag to another IMAP folder
within the same IMAP account = all messages were moved to the destination
folder= correct behavior
I did a non-continuous mutiple select of 3 messages within an expanded thread
while in thread view, repeated the steps above and both worked as expected.
Reporter, if you can try your scenario again with a build form 2-25-2001 or
later to see if this now fixed that would be great.  If it's not fixed, please
read my scenarios in comments 2-26 and 2-27 and let me know if I'm missing
something in these tests
(Assignee)

Comment 15

16 years ago
I am not able to drag multiple messages without pressing ctrl key. only
one message gets moved. 
(Assignee)

Comment 16

16 years ago
marking wfm, esther showed me how to do it, thanks.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 17

16 years ago
Verified wfm.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.