IE specific dynamic content method on http://burial.interpab.com.pl

RESOLVED FIXED

Status

Tech Evangelism Graveyard
Polish
P3
normal
RESOLVED FIXED
17 years ago
3 years ago

People

(Reporter: Marcin Garski, Assigned: Jacek Piskozub)

Tracking

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)
BuildID:    2001091712

Please extract file (adres is in URL forum) and open that page, then move mouse 
to the left on the pictures (they are links) and pictures disappear so you 
can't click on link. In Opera pictures didn't disappear, in IE 5.5 SP1 it 
disappear but the place where images would be appear as a free space and you 
can click on it.

Reproducible: Always
Steps to Reproduce:
1. Open extracted page
2. Move mouse to the left side (on the images)
3.

Actual Results:  Images disappear.

Expected Results:  Do like it is in IE that I have describe in "Description" 
field

Comment 1

17 years ago
Browser, not engine --> Event Handling
Assignee: rogerl → joki
Component: Javascript Engine → Event Handling
QA Contact: pschwartau → madhur

Comment 2

17 years ago
ok, this page is evangelism

on every mouseover of an image the js console gives an error: ReplaceMe is not
defined.
from source:

 <div class=opis id=ReplaceMe></div></td></tr>
<tr>
<td vAlign=top><a onmouseover="img_on('Main'); window.status =
'G?ówna';&#13;&#10;&#9;&#9;&#9;ReplaceMe.innerHTML = 'Strona
G?ówna';&#13;&#10;&#9;&#9;&#9;return true" 

etc.there's no document.getElementById("ReplaceMe") anywhere.

if Marcin hasn't written this, we need to find contact data.
Assignee: joki → bclary
Status: UNCONFIRMED → NEW
Component: Event Handling → Europe: Central
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: madhur → zach
Version: other → unspecified
-> default owners.
Assignee: bclary → piskozub
QA Contact: zach → pali

Comment 4

17 years ago
from mail i recieved:
I didn't wrote above code, the person who do this can be reach at:
burial@interpab.com.pl (him site: http://burial.interpab.com.pl).
Another page you can watch is at:
http://garski.republika.pl/mozilla1.zip
Move mouse to word "ENGLISH" and below, you get the same effect.
--
Best regards
Marcin Garski
Jacek was CCed on this mail, just putting this where it belongs.

Marcin, thanks for the reply, it's appreciated, but please use bugzilla if
you're replying to a mail you get when something is changed to a bug.
(Assignee)

Comment 5

17 years ago
I can contact the author but I do not see what exactly he is supposed to change. 

JavaScript is not my virtue. It is clear that the code is IE4+ specific. It
would see to me that something like

<div class=opis id=ReplaceMe></div></td></tr>
<tr>
<td vAlign=top><a if (document.getElementById){
dupa=document.getElementById("ReplaceMe");
onmouseover="img_on('Main'); window.status =
'G?ówna';&#13;&#10;&#9;&#9;&#9;dupa.innerHTML = 'Strona
G?ówna';&#13;&#10;&#9;&#9;&#9;return true"}

is standard compliant and should work with both IE and Mozilla but it still
gives "dupa not defined" error. Trying
document.getElementById("ReplaceME").innerHTML in place of ReplaceMe.innerHTML
results in a syntax error, too.

Is this because the code is embedded inside <a> </a> tags, instead of <script>
</script>?

Ferdinand: Could you be more specific how to repair this? It would help a lot in
my communication with the page author.


(Assignee)

Comment 6

17 years ago
OK. I got it. Forget what I wrote above. It should be:

 document.getElementById('ReplaceMe').innerHTML 
everywhere where we have ReplaceMe.innerHTML

Take note of the single quotation marks as this happens inside the standard ("
") quotation.
It seems I learned a lot of JavaScript today :-(

BTW, the vanishing pictures are the result of not copying the *_on.gif files
which are used 
(Assignee)

Comment 7

17 years ago
The corrected complete of files can be found at
http://eden.iopan.gda.pl/~piskozub/interpab.zip
The only difference except copying all graphic files is the above mentioned
change in Menu.htm.

I changed the summary as the disappearing images were the result of missing
pictures used with onmouseover and onmouseout.
Summary: Links on images disappear when coursor is on it. → IE specific dynamic content method on http://burial.interpab.com.pl
(Assignee)

Comment 8

17 years ago
The author of the page was notified about the error and the proposed solution.
(Reporter)

Comment 9

17 years ago
I know that when you add "missing pictures used with onmouseover" page will be 
displayed properly, but when you don't have "missing pictures" page in Mozilla 
is displayed as I wrote above "disappearing pictures" (that is the thing I want 
to report) in Opera pictures didn't disappear just are the same as before mouse 
move, in IE 5.5 SP1 it disappear but the place where images would be appear as 
a free space and you can click on it.
Please check the second page http://garski.republika.pl/mozilla1.zip and you 
get the same effect.

I probably know why that is happen, when IE can't load some images the place 
where images should appear as a free space [http://garski.republika.pl/ie.jpg] 
the same site in Mozilla [http://garski.republika.pl/mozilla.jpg].
As you see in Mozilla you don't kown that 2 images wasn't loaded. So back to 
subject when you move mouse on javascript buttons (they aren't loaded) they 
just like above 2 pictures disappear/didn't displayed.
(Assignee)

Comment 10

17 years ago
I believe you've hit the problem decribed in bug 92284. Read this comment by
Doron Rosenberg on 2001-08-31:

>what  the reporter means is, when you onmouseover over the images, the image is
> replaced with box (temp placeholder) while it waits for the new image to be
> downloaded. Other browsers keep the old image shown until the new one has been
> fully fetched. 

The image disappears in absence of the new one that should replace it, exactly
because it is replaced by the black placeholder box. So this part of the bug is
a dup of bug 92284. I will mark the the remaining "Evangelic" part fixed when
the page is changed to use document.getElementById.
(Assignee)

Comment 11

17 years ago
Sorry: I meant bug 92248 :-(
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

16 years ago
Priority: -- → P2
(Assignee)

Comment 12

16 years ago
It seems the page is fixed. Marking as such. 

Please QA the bug.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
OS: Linux → All
Priority: P2 → P3
Hardware: PC → All
Resolution: --- → FIXED
Target Milestone: --- → Future
tech evang june 2003 reorg
Component: Europe: Central → Polish
Target Milestone: Future → ---
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.