Context menu for systray icon should display default option in bold

RESOLVED WONTFIX

Status

SeaMonkey
UI Design
--
minor
RESOLVED WONTFIX
17 years ago
4 years ago

People

(Reporter: Daniel Mario Vega (Restore MNG Support --> #18574), Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fix-in-hand)

Attachments

(1 attachment)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.4+) Gecko/20010925
BuildID:    2001092503

When you right click on mozilla turbo mode systray icon, a popup menu appears.
It is common practice to show the default option in bold. This default option is
the action executed when you double-click that icon. 

If you show that option in bold the user will have a visual feedback about will
happen if he double-click the mozilla systray icon.



Reproducible: Always
Steps to Reproduce:
1. Turn on QuickLaunch feature on preferences.
2. Right click con mozilla systray icon


Actual Results:  A popup menu appears with no default option

Expected Results:  A popup menu should appear with a default option displayed in
bold

See the "fState" field on MENUITEMINFO structure and MFS_DEFAULT constant

http://msdn.microsoft.com/library/en-us/winui/menus_3n1u.asp
Blocks: 75599

Comment 1

17 years ago
On Win98, double-clicking the turbo icon can focus an existing browser window, 
whereas selecting "Navigator" always opens a new one.  That should probably be 
fixed before we mark "Navigator" as the default option on the meun.  See also:

bug 99856  double-clicking turbo icon unmaximizes an open browser window
bug 91129  double clicking Mozilla turbo icon w/ no open windows ignores 
            startup pref ("open navigator and mail when i start mozilla")
bug 101025 double-clicking turbo icon focuses download window
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Richt click on turbo mode systray icon, should display popup menu with default option in bold → Context menu for systray icon should display default option in bold
QA Contact: sairuh → tpreston

Comment 2

16 years ago
Marking p4 and mozilla1.1
Status: NEW → ASSIGNED
Priority: -- → P4
Target Milestone: --- → mozilla1.1

Comment 3

16 years ago
-> default assignee
Assignee: pchen → trudelle
Status: ASSIGNED → NEW
QA Contact: tpreston → sairuh
Target Milestone: mozilla1.1 → ---

Comment 4

16 years ago
->law
Assignee: trudelle → law

Comment 5

16 years ago
I have/had a patch for this.

One note: current implementation will open any or all of 
navigator/composer/mail when you double click (depending on user prefs), if 
there are no windows open when you double-click.  I don't think we'll deal with 
that (Navigator will always appear as the "default").
Target Milestone: --- → mozilla0.9.9

Comment 6

16 years ago
Created attachment 68180 [details] [diff] [review]
patch

Updated

16 years ago
Keywords: nsbeta1
Whiteboard: fix-in-hand

Comment 7

16 years ago
An alternative approach would be to add a new menu item at the top of the popup
menu, titled "Launch Mozilla" (for example), which would be bold. That seems
logical to me, since the default action is neither of the alternatives presently
displayed in the popup menu.

This menu item would do the same thing as when you double-click the icon (e.g.
launch programs based on user prefs).

Comment 8

16 years ago
Working on this stuff next.
Target Milestone: mozilla0.9.9 → mozilla1.0

Comment 9

16 years ago
nsbeta1- per ADT triage team, ->1.2
Keywords: nsbeta1 → nsbeta1-
Target Milestone: mozilla1.0 → mozilla1.2
QA Contact: sairuh → tpreston

Updated

16 years ago
No longer blocks: 75599

Updated

16 years ago
Blocks: 75599
Product: Core → Mozilla Application Suite
Assignee: law → jag
Priority: P4 → --
QA Contact: tpreston
Target Milestone: mozilla1.2alpha → ---

Comment 10

9 years ago
Turbo mode is dead in SeaMonkey 2.0a
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.