Closed Bug 1016047 Opened 6 years ago Closed 5 years ago

Stop box model highlighter causing toolbox jumping on small screen

Categories

(DevTools :: Inspector, defect)

x86
macOS
defect
Not set

Tracking

(firefox31 verified, firefox32+ verified, firefox33 verified)

VERIFIED FIXED
Firefox 33
Tracking Status
firefox31 --- verified
firefox32 + verified
firefox33 --- verified

People

(Reporter: bgrins, Assigned: miker)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Attached image jumping.gif
See attached gif.  This seems to happen when hovering between non-highlighted nodes (like a doctype) and one that is highlighted (like <body>). Also seems to happen mostly when the height of the page content is relatively small, but I think I've seen it happen at a variety of sizes.
I don't think this has anything to do with the node info bar - I've removed it from the DOM and see the same problem
Mike, can you take a look at this?
Flags: needinfo?(mratcliffe)
(In reply to Brian Grinstead [:bgrins] from comment #1)
> I don't think this has anything to do with the node info bar - I've removed
> it from the DOM and see the same problem

I think it is caused by the SVG canvas. Whatever it is I am sure we can find some solution event if that means changing our injection point.
Assignee: nobody → mratcliffe
Status: NEW → ASSIGNED
Flags: needinfo?(mratcliffe)
Setting height="0" on the SVG stops this bug from happening. It's still sized to cover the viewport, probably because its parent <stack> does that to its children.
(In reply to Markus Stange [:mstange] from comment #4)
> Setting height="0" on the SVG stops this bug from happening. It's still
> sized to cover the viewport, probably because its parent <stack> does that
> to its children.

Thanks for letting me know and saving me some experimentation.
Summary: Box model highlighter causes toolbox jumping when screen is small → Stop box model highlighter causing toolbox jumping on small screen
Comment on attachment 8438464 [details] [diff] [review]
highlighter-jumping-1016047.patch

Review of attachment 8438464 [details] [diff] [review]:
-----------------------------------------------------------------

Works for me
Attachment #8438464 - Flags: review?(bgrinstead) → review+
This is ready to land, yes?
I am landing it in a minute... had to make sure it plays well with other patches:
https://tbpl.mozilla.org/?tree=Try&rev=90451d83715e
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/3d233f6ed71f
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 33
Mike, I believe that we will also need to uplift this to Aurora, correct?
Flags: needinfo?(mratcliffe)
Comment on attachment 8438464 [details] [diff] [review]
highlighter-jumping-1016047.patch

(In reply to Brian Grinstead [:bgrins] from comment #12)
> Mike, I believe that we will also need to uplift this to Aurora, correct?

Yes, it will.

Approval Request Comment
[Feature/regressing bug #]: Box model highlighter
[User impact if declined]: Display will jump when the devtools are opened in a small browser window.
[Describe test coverage new/current, TBPL]: Green on try.
[Risks and why]: No risks, very simple patch.
[String/UUID change made/needed]: None
Attachment #8438464 - Flags: approval-mozilla-aurora?
Flags: needinfo?(mratcliffe)
Comment on attachment 8438464 [details] [diff] [review]
highlighter-jumping-1016047.patch

Aurora approval granted.

Should we pursue an uplift for beta? (When was the box model highlighter introduced? Is this a regression?)
Attachment #8438464 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Comment on attachment 8438464 [details] [diff] [review]
highlighter-jumping-1016047.patch

(In reply to Lawrence Mandel [:lmandel] from comment #14)
> Comment on attachment 8438464 [details] [diff] [review]
> highlighter-jumping-1016047.patch
> 
> Aurora approval granted.
> 
> Should we pursue an uplift for beta? (When was the box model highlighter
> introduced? Is this a regression?)

Wow, time flies... yes we should.

Approval Request Comment
[Feature/regressing bug #]: Box model highlighter
[User impact if declined]: Display will jump when the devtools are opened in a small browser window.
[Describe test coverage new/current, TBPL]: Green on try.
[Risks and why]: No risks, very simple patch.
[String/UUID change made/needed]: None
Attachment #8438464 - Flags: approval-mozilla-beta?
Comment on attachment 8438464 [details] [diff] [review]
highlighter-jumping-1016047.patch

Accepting because it decreases the user experience. 
Michael, FYI, for next time, please note that we do not accept "no risk" as potential evaluation. Every patch has risk!
Attachment #8438464 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
https://hg.mozilla.org/releases/mozilla-beta/rev/bedb92100da2

FWIW, you don't need to set checkin-needed on uplifts. We have separate bug queries for them.
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:31.0) Gecko/20100101 Firefox/31.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:32.0) Gecko/20100101 Firefox/32.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:33.0) Gecko/20100101 Firefox/33.0

Verified fixed on:
- Firefox 31 beta 7, build ID: 20140703154127
- Latest Firefox Aurora, build ID: 20140706004001
- Latest Firefox Nightly, build ID: 20140706030226
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.