Closed Bug 1016473 Opened 8 years ago Closed 8 years ago

sccache failed with BadZipfile: File is not a zip file

Categories

(Firefox Build System :: General, defect)

defect
Not set
normal

Tracking

(firefox32 wontfix, firefox33 wontfix, firefox34 fixed, firefox-esr24 unaffected, firefox-esr31 unaffected)

RESOLVED FIXED
mozilla34
Tracking Status
firefox32 --- wontfix
firefox33 --- wontfix
firefox34 --- fixed
firefox-esr24 --- unaffected
firefox-esr31 --- unaffected

People

(Reporter: mshal, Assigned: glandium)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

On a try build, I hit this in B2G Desktop Linux x64 Opt:

python2.7 /builds/slave/try-l64_g-00000000000000000000/build/sccache/sccache.py /tools/gcc-4.7.3-0moz1/bin/g++ -o TestDictionaryBinding.o -c -I../../../dist/stl_wrappers -I../../../dist/system_wrappers -include /builds/slave/try-l64_g-00000000000000000000/build/config/gcc_hidden.h -DMOZILLA_INTERNAL_API -DIMPL_LIBXUL -DMOZ_GLUE_IN_PROGRAM -DNO_NSPR_10_SUPPORT -I/builds/slave/try-l64_g-00000000000000000000/build/dom/bindings/test -I. -I../../../dist/include/mozilla/dom -I/builds/slave/try-l64_g-00000000000000000000/build/dom/bindings -I/builds/slave/try-l64_g-00000000000000000000/build/js/xpconnect/src -I/builds/slave/try-l64_g-00000000000000000000/build/js/xpconnect/wrappers -I.. -I../../../dist/include  -I/builds/slave/try-l64_g-00000000000000000000/build/obj-firefox/dist/include/nspr -I/builds/slave/try-l64_g-00000000000000000000/build/obj-firefox/dist/include/nss  -I/builds/slave/try-l64_g-00000000000000000000/build/obj-firefox/dist/include -I/builds/slave/try-l64_g-00000000000000000000/build/modules/zlib/src    -fPIC   -DMOZILLA_CLIENT -include ../../../mozilla-config.h -MD -MP -MF .deps/TestDictionaryBinding.o.pp  -Wall -Wpointer-arith -Woverloaded-virtual -Werror=return-type -Werror=int-to-pointer-cast -Wtype-limits -Wempty-body -Wsign-compare -Wno-invalid-offsetof -Wcast-align -DMOZ_ENABLE_JS_DUMP -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -std=gnu++0x -pthread -pipe -Wno-uninitialized  -DNDEBUG -DTRIMMED -g -Os -freorder-blocks  -fomit-frame-pointer     /builds/slave/try-l64_g-00000000000000000000/build/obj-firefox/dom/bindings/TestDictionaryBinding.cpp

Traceback (most recent call last):
  File "/builds/slave/try-l64_g-00000000000000000000/build/sccache/server.py", line 312, in run_command
    for result in _run_command(job):
  File "/builds/slave/try-l64_g-00000000000000000000/build/sccache/server.py", line 264, in _run_command
    cache = CacheData(data)
  File "/builds/slave/try-l64_g-00000000000000000000/build/sccache/cache.py", line 25, in __init__
    self._zip = ZipFile(self._data, 'r' if data else 'w', ZIP_DEFLATED)
  File "/tools/python27/lib/python2.7/zipfile.py", line 714, in __init__
    self._GetContents()
  File "/tools/python27/lib/python2.7/zipfile.py", line 748, in _GetContents
    self._RealGetContents()
  File "/tools/python27/lib/python2.7/zipfile.py", line 763, in _RealGetContents
    raise BadZipfile, "File is not a zip file"
BadZipfile: File is not a zip file
make[5]: *** [TestDictionaryBinding.o] Error 1
make[5]: Leaving directory `/builds/slave/try-l64_g-00000000000000000000/build/obj-firefox/dom/bindings/test'
make[4]: *** [dom/bindings/test/compile] Error 2
make[4]: Leaving directory `/builds/slave/try-l64_g-00000000000000000000/build/obj-firefox'
make[3]: *** [compile] Error 2
make[3]: Leaving directory `/builds/slave/try-l64_g-00000000000000000000/build/obj-firefox'
make[2]: *** [default] Error 2
make[2]: Leaving directory `/builds/slave/try-l64_g-00000000000000000000/build/obj-firefox'
make[1]: *** [realbuild] Error 2
make[1]: Leaving directory `/builds/slave/try-l64_g-00000000000000000000/build'
make: *** [build] Error 2

A re-trigger was green, so I assume this is intermittent. glandium, any idea what would cause this?
Where was the red and where was the green? (as in scl*, usw2 or use1?)
red: try-linux64-spot-377 (usw2)
green: bld-linux64-ix-049 (scl3)

I'll try to retrigger it a few times to see if I can get another one on usw2.
I got a few more on usw2: try-linux64-spot-306, try-linux64-spot-408, and try-linux64-spot-301 - all green. I'm not sure what was unique about the build on spot-377.
For reference, the try push is at: https://tbpl.mozilla.org/?tree=Try&rev=0ab8a195c840
Blocks: 1008015
https://tbpl.mozilla.org/php/getParsedLog.php?id=42547221&tree=Mozilla-Inbound

This seems to be hitting more frequently lately. Any idea what's going on, Mike?
Flags: needinfo?(mh+mozilla)
https://tbpl.mozilla.org/php/getParsedLog.php?id=43904326&tree=Mozilla-Inbound
Linux mozilla-inbound build on 2014-07-15 23:21:51 PDT for push e8d086d9a01a
Duplicate of this bug: 1045384
Attachment #8463755 - Flags: review?(mshal)
Flags: needinfo?(mh+mozilla)
Assignee: nobody → mh+mozilla
Comment on attachment 8463755 [details] [diff] [review]
Gracefully handle bad zip data gotten from storage

Any idea why we're actually getting the bad data back? Is there a chance that the bad data will still be a valid, but wrong, zip file?
Attachment #8463755 - Flags: review?(mshal) → review+
Depends on: 1045923
https://tbpl.mozilla.org/php/getParsedLog.php?id=45736431&tree=B2g-Inbound

Is this ok to land? :-)
Flags: needinfo?(mh+mozilla)
(In reply to Ed Morley [:edmorley] from comment #26)
> Is this ok to land? :-)

Mike?


https://tbpl.mozilla.org/php/getParsedLog.php?id=46448341&tree=B2g-Inbound
Fixed by bug 1045923
Status: NEW → RESOLVED
Closed: 8 years ago
Flags: needinfo?(mh+mozilla)
Resolution: --- → FIXED
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.