Closed Bug 1016517 Opened 5 years ago Closed 2 years ago

[B2G][Flame][Settings] Redraw on keyboard settings menu is showing black line during transitions

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.3 affected, b2g-v1.4 affected, b2g-v2.0 affected)

RESOLVED WONTFIX
Tracking Status
b2g-v1.3 --- affected
b2g-v1.4 --- affected
b2g-v2.0 --- affected

People

(Reporter: rpribble, Unassigned)

Details

(Whiteboard: [2.0-flame-test-run-1], [FT:System-Platform])

Attachments

(2 files)

Attached video video.3gp
Description:
When the user selects 'Built-in Keyboard' in the keyboard settings menu to try and makes changes and then backs out of that menu, the will see the next screen slide in from the right with a black line or window.  Then, when they try and 'x' out of the keyboard settings menu, they will have to tap the 'x' twice in order for the gesture to be acknowledged. 

Repro Steps:
1) Updated Flame to BuildID: 20140527040202
2) Tap the settings icon
3) Select the keyboard menu
4) Select 'build-in keyboard'
5) Tap the back arrow
6) Tap the 'x' in upper left

Actual:
Built-in Keyboard menu redraw is not handled very gracefully.

Expected:
User does not see black lines or windows when flipping through setting menus.

Environmental Variables:
Device: Flame v2.0 MOZ ril
BuildID: 20140527040202
Gaia: 6a391274cd436f8f0d1fad2db8c6b4805703259c
Gecko: cbe4f69c2e9c
Version: 32.0a1
Firmware Version: v1.2-device.cfg

Notes:

Repro frequency: 100%
See attached: Video, logcat
Attached file Logcat.txt
This issue also occurs on the Buri v1.4 MOZ ril.

Environmental Variables:
Device: Buri v1.4 MOZ ril
BuildID: 20140521000202
Gaia: 93623f6435849cc9f54d9996e8e64828ac9091d1
Gecko: 12fe2b67a099
Version: 30.0
Firmware Version: v1.2-device.cfg

User sees black line or window on keyboard menu transitions.
This issue also occurs on the Buri v1.3 MOZ ril.

Environmental Variables:
Device: Buri v1.3 MOZ ril
BuildID: 20140527083838
Gaia: c5b1ea21188fc3cbf84bb6d11d8f4d26d6c8f83d
Gecko: c8af9fdccab4
Version: 28.0
Firmware Version: v1.2-device.cfg

User sees black line or window on keyboard menu transitions.
This issue partially occurs on the Flame v1.4 MOZ ril.

Environmental Variables:
Device: Flame v1.4 MOZ ril
BuildID: 20140527000202
Gaia: 0542778892a294d224e75af4a76be5d42938bc90
Gecko: d583ae109f54
Version: 30.0
Firmware Version: v1.2-device.cfg

The user will see the redraw occur with black lines, but will not encounter the 'x' to exit the menu but a back arrow instead.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1016280
I think this issue is different from  bug 1016280, this is about the black line appearing during the app transition while bug 1016280 is about the wrong "X" icon appearing on the settings page.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Oh~ Thanks Rudy! :)
If this is an issue, it should belong to window management or graphics.
I could see the same issue when invoking email app from contacts app.
Component: Gaia::Settings → Gaia::System::Window Mgmt
Whiteboard: [2.0-flame-test-run-1] → [2.0-flame-test-run-1], [FT:System-Platform]
This is expected when you switch between apps and now we treat keyboard 'settings' and setting as two different apps. I think this should go be duped.
Firefox OS is not being worked on
Status: REOPENED → RESOLVED
Closed: 5 years ago2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.