If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[B2G][Clock]The user is able to change the clock from digital to analog by tapping on an alarm

RESOLVED DUPLICATE of bug 984897

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED DUPLICATE of bug 984897
3 years ago
3 years ago

People

(Reporter: DerekH, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [2.0-flame-test-run-1][systemsfe], URL)

Attachments

(1 attachment)

Created attachment 8429615 [details]
Logcat 2.0 Flame

Description:
When the user is trying to turn on or off an alarm, or go into edit mode, the user instead will change the clock from analog to digital or vice-versa

Repro Steps:
1) Update a Flame to BuildID: 20140527040202
2) Open Clock app
3) Tap on new alarm in upper right corner
4) Tap done to create a new alarm
5) Tap on the far left or right side of the alarm

Actual:
Clock changes from analog to digital or vice-versa

Expected:
If tapping on the right side the alarm is turned on or off. If tapping on the left side the user goes into the edit mode of the alarm

2.0 Environmental Variables:
Device: Flame 2.0
BuildID: 20140527040202
Gaia: 6a391274cd436f8f0d1fad2db8c6b4805703259c
Gecko: cbe4f69c2e9c
Version: 32.0a1
Firmware Version: v10G-2

Keywords: Digital, Analog, Switch, Change, Alarm

Notes: This issue occur with multiple alarms set also

Repro frequency: 100%
See attached: Logcat, Video - https://www.youtube.com/watch?edit=vd&v=2nbxQ8SFyb0
This issue DOES occur for Open C 2.0

2.0 Environmental Variables:
Device: Open_C 2.0
BuildID: 20140527040202
Gaia: 6a391274cd436f8f0d1fad2db8c6b4805703259c
Gecko: cbe4f69c2e9c
Version: 32.0a1
Firmware Version: P821A10V1.0.0B06_LOG_DL
This issue does NOT occur on Open C 1.3

Open C 1.3:
1.3 Environmental Variables:
Device: Open_C 1.3
BuildID: 20140505052400
Gaia: Unknown Git commit; build date shown here.
Gecko:
Version: 28.0
Firmware Version: P821A10V1.0.0B06_LOG_DL

User Agent 1.3 Open C: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0



This issue does NOT occur on Flame 1.3

1.3 Environmental Variables:
Device: Flame 1.3
BuildID: 20140520094859
Gaia: a73235d23685e9898f40647cebd83b3fcbfd0117
Gecko: Unknown
Version: 28.0
Firmware Version: v10G-2

User Agent 1.3 Flame: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0
User Agent 2.0 Flame: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
Can we reproduce this with edge gestures disabled?
Keywords: qawanted
This issue does not reproduce without edge gestures enabled.

Environmental Variables:
Device: Flame
BuildID: 20140528073011
Gaia: 389dee3293891002f825ea1d5d92283094b7d931
Gecko: 5add3261493b
Version: 32.0a1
Keywords: qawanted
QA Contact: jmercado
Do you mean this doesn't reproduce with edge gestures disabled?
Flags: needinfo?(jmercado)
Yes, this issue does not reproduce with edge gestures disabled.
Flags: needinfo?(jmercado)
This is likely a dupe of the hidpi touch bug, but I'll let Etienne triage this to confirm that.
Blocks: 918792
blocking-b2g: --- → 2.0?
Component: Gaia::Clock → Gaia::System::Window Mgmt

Updated

3 years ago
Whiteboard: [2.0-flame-test-run-1] → [2.0-flame-test-run-1][systemsfe]
Etienne - Is this a dupe of bug 984897?
Flags: needinfo?(etienne)
(In reply to Jason Smith [:jsmith] from comment #9)
> Etienne - Is this a dupe of bug 984897?

yes, good thing we have a HiDPI reference device now :)
Flags: needinfo?(etienne)

Updated

3 years ago
No longer blocks: 918792
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 984897

Updated

3 years ago
blocking-b2g: 2.0? → ---
You need to log in before you can comment on or make changes to this bug.