Moz hangs after shift-tabbing too far in address card editor

VERIFIED DUPLICATE of bug 100921

Status

SeaMonkey
MailNews: Address Book & Contacts
--
critical
VERIFIED DUPLICATE of bug 100921
17 years ago
14 years ago

People

(Reporter: Joe Infla, Assigned: chuang)

Tracking

({access, hang})

Trunk
x86
Windows 98
access, hang

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.4+) Gecko/20010924
BuildID:    2001092403

When editing an addressbook card, tabbing and shift-tabbing moves forward and
back between fields (first & last name, etc.), but shift-tabbing while in the
first field causes all mozilla components to freeze up, forcing restart of Mozilla.

Reproducible: Always
Steps to Reproduce:
1. Open Address Book.
2. Open a card in its own window (dbl-click).
3. Press tab, then shift-tab twice.
4. Alternately, just shift-tab from first field.

Actual Results:  Cursor blinks rapidly and all open mozilla windows freeze. 
Must use task manager to shut down.
Any unsaved information in that card or other open windows is lost.

Expected Results:  Mozilla shouldn't freeze.  Focus should probably go to cancel
button.

Comment 1

17 years ago
Confirmed with build 2001 092503 on Win98.  I got the dialog by clicking 
the "new card" button instead of by editing an existing card.

Tabbing from the cancel button skips the drop-down at the top and goes straight 
to the first text field.  Could that be related to the hang?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: access, hang

Comment 2

17 years ago

*** This bug has been marked as a duplicate of 100921 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
Verified Duplicate. Branch build 2001-09-27-05: WinMe, it appears to be working
now without a hang.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.