[Camera][Flame] Switching between camera and video - camera gets stuck in video mode

RESOLVED DUPLICATE of bug 1025197

Status

Firefox OS
Gaia::Camera
RESOLVED DUPLICATE of bug 1025197
4 years ago
3 years ago

People

(Reporter: marcia, Assigned: dmarcos)

Tracking

({regression})

unspecified
2.0 S5 (4july)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.0+)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8429781 [details]
Logcat while reproducing the issue

Flame, while running today's master build:

Gaia   6a391274cd436f8f0d1fad2db8c6b4805703259c
SourceStamp cbe4f69c2e9c
BuildID 20140527040202
Version 32.0a1
10G base

STR:
1. Switch between camera and video recorder several times
2. Eventually end up in the state in the attached screenshot

In this state, I am no longer able to stop the video recording because the incorrect camera UI is shown. I have been able to reproduce this multiple times on this build by just switching between the two camera states.

Screenshot attached and logcat coming.
(Reporter)

Comment 1

4 years ago
Created attachment 8429783 [details]
Screenshot of issue

Here is a shot of the camera stuck in Video mode - note that even though video recording is happening, the camera icon is showing. In this state I cannot stop the video and I have to close the camera app.
Let's also confirm this doesn't reproduce on 1.4.

Updated

4 years ago
Keywords: regressionwindow-wanted → qawanted
QA Contact: dharris
I was unable to get this issue to reproduce after 20 attempts on Flame 1.4

Environmental Variables:
Device: Flame 1.4
Build ID: 20140610000204
Gaia: 57c6a24f7c7d16aac132f3cecd3ff9ee8d53cf78
Gecko: 54a7aa1a0423
Version: 30.0 (1.4) 
Firmware Version: v10G-2

The camera app could be switched between video and camera without getting stuck
Keywords: qawanted
How many times do you switch between camera & video recorder before you hit this bug? What's the reproduction rate?
Keywords: qawanted
This is more of a timing bug. I have been able to switch between camera and video recorder 3 times and get this bug to occur, and it has taken me 30 times switching between camera and video to get this bug to occur. The reproduction rate is ~ 70%

Flame 2.0

Environmental Variables:
Device: Flame 2.0
Build ID: 20140610000223
Gaia: 8d865839d932bfbd5e157f376f74d8cb12bfdd51
Gecko: 1d4046a8cb6c
Version: 32.0a2 (2.0) 
Firmware Version: v10G-2

User Agent 1.3 Open C: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: QAnalyst-Triage?
Flags: needinfo?(jmitchell)
Keywords: qawanted
Jason - this Repro's in 2.0 but not 1.4; should we remove the regression keyword?
Flags: needinfo?(jmitchell)

Updated

4 years ago
blocking-b2g: --- → 2.0?
Keywords: regressionwindow-wanted
I'm not clear on the steps to reproduce. The screen-shot appears to show the camera to be recording a video, but nowhere in the steps does it indicate video recording was initiated. Can you clarify the steps to get to the screen-shotted state?
Flags: needinfo?(mozillamarcia.knous)

Updated

4 years ago
blocking-b2g: 2.0? → 2.0+
QA Wanted to address comment 7.
Keywords: regressionwindow-wanted → qawanted
1) Open Camera App
2) Quickly switch between camera and video recording
3) While switching back and fourth, try and take a picture at the same time

The Camera icon will highlight blue as if the user is taking a picture, but there will be a video recording sound that plays, as well as a recording timer in the top left. The user cannot stop the recording unless the app is closed, and the recording is not saved.
Flags: needinfo?(jmitchell)
Keywords: qawanted
Flags: needinfo?(jmitchell)
Josh - The developer was asking for a video here, so qawanted should have been reflagged here to get that missing info.
Flags: needinfo?(jmitchell)
Keywords: qawanted
(In reply to Jason Smith [:jsmith] from comment #10)
> Josh - The developer was asking for a video here, so qawanted should have
> been reflagged here to get that missing info.

Sorry; was not seeing that request anywhere - Comment 7 does drop the word 'video' a lot but only in discussion of the state shown on the screenshot and I think maybe we wrongly interpreted that as 'steps-wanted'. That isn't to say we shouldn't have attached one in the first-place! 

Video link: http://youtu.be/XYLeBcU6jGc

The quality is not the best as it takes me two hands to repro this bug (it basically requires spamming buttons to switch back and forth between modes while hitting the shutter-button).
Flags: needinfo?(jmitchell)
Keywords: qawanted

Updated

4 years ago
Keywords: regressionwindow-wanted
(Reporter)

Comment 12

4 years ago
(In reply to Wilson Page [:wilsonpage] from comment #7)
> I'm not clear on the steps to reproduce. The screen-shot appears to show the
> camera to be recording a video, but nowhere in the steps does it indicate
> video recording was initiated. Can you clarify the steps to get to the
> screen-shotted state?

Wilson: All I was doing to get in that state was to switch between camera and video mode. Usually for me it happens after about the 10th time.

I can still reproduce on Flame using:

Gaia   dfc4703bb81d1fa4f2087a1a6124b47a80a5d1de
SourceStamp 80431d4fd0da
BuildID 20140616040202
Version 33.0a1
Base image: 121

I think one thing that may not be clear is that I am actually making contact with the shutter button when I am switching.
Flags: needinfo?(mozillamarcia.knous)

Comment 13

4 years ago
Diego says he will take this up. Assigning to him.
Assignee: nobody → dmarcos
QA Contact: dharris → jmercado
I do not believe we will be able to attain this regression window. The further back we go the more prominent several other camera bugs become such as 1010378 
I believe that issue is masking this bugs issue preventing accurate results.

Here is the data I did get:
B2G Inbound Regression Window:

Last Working:
Device: Flame Master
Build ID: 20140506233003
Gaia: d4ab86bcf2d9c24f4d40ada0895216607f13899f
Gecko: c4b54011a2fb
Version: 32.0a1 (Master)
Firmware Version: v121-2

First Broken:
Device: Flame Master
Build ID: 20140507023004
Gaia: 9d1352a320ab29c8979f2add173e59433963e46a
Gecko: 986c5aed5a88
Version: 32.0a1 (Master)
Firmware Version: v121-2

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/d4ab86bcf2d9c24f4d40ada0895216607f13899f...9d1352a320ab29c8979f2add173e59433963e46a

but this push-log does not look legit, as no issues in there seem to be related to the camera further making me think this issue is blocked by the others and that the last working is not truly the last working but instead simply the last (regressing backward) where this issue is visible.
QA Whiteboard: QAnalyst-Triage? → [QAnalyst-Triage+]
Keywords: regressionwindow-wanted

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
(Assignee)

Comment 15

4 years ago
Created attachment 8445460 [details]
stuckActiveState.MOV

I reproduce a similar problem but with the HUD buttons. I have no 100% certainty but I think this is the same root issue as one bug reported 2 months ago: https://bugzilla.mozilla.org/show_bug.cgi?id=995475#c42
(Assignee)

Comment 16

4 years ago
On same cases and on multiple finger taps on screen the elements end up stuck on the active state
(Assignee)

Updated

4 years ago
Depends on: 995475
(Assignee)

Comment 17

3 years ago
This is pretty difficult to reproduce so I would not block on it
This is very likely the same issue as bug 1025197, a patch for which has just landed on b2g-inbound and master, and should be landing on 1.4 and 2.0.

Updated

3 years ago
Target Milestone: --- → 2.0 S5 (4july)
(In reply to Mike Habicher [:mikeh] from comment #18)
> This is very likely the same issue as bug 1025197, a patch for which has
> just landed on b2g-inbound and master, and should be landing on 1.4 and 2.0.

Agree.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1025197
You need to log in before you can comment on or make changes to this bug.