[Flame][v1.4][SMS]The contact can be added in To field more than once.

RESOLVED WONTFIX

Status

Firefox OS
Gaia::SMS
RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: greatwall2686, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.3 affected, b2g-v1.4 affected)

Details

(Whiteboard: torch)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8429959 [details]
2014-5-28-SMS.jpg

Description:[Flame][V1.4][sms]:The contact can be added in To field more than once.

* Reproduction steps:
  1. New a message
  2. Choose a contact more than once 

* Expected result:
  The contact name will be displayed only once.

* Actual result:
  The contact name is displayed as many times as  you choose.

* Reproduction build:(Buri - Firefox OS V1.4 outside)
 - Gaia      17b102ee8d9a724b62285547cc5f1c5d30bfb01c
 - Gecko     https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/95be84248033
 - BuildID   20140520000201
 - Version   30.0

* Reproduction Frequency
  - 100%
It's been done on purpose. If the user wants to add a contact twice, why should we prevent it?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
I think the point the reporter is making is that you shouldn't be able to add the same contact twice, which seems valid. Why would you want the same contact showing in the to list three times in a row?

My guess is that this isn't a regression, but let's check 1.3 to be sure.
Status: RESOLVED → REOPENED
Ever confirmed: true
Keywords: qawanted
Resolution: WONTFIX → ---

Comment 3

4 years ago
Same happens on 1.3 Buri - the same contact is displayed in the 'To' field multiple times if has been added multiple times.

Buri 1.3
BuildID: 20140529024024
Gaia: 5bd226b03a2d63dfe9df204f7c0afb9984e8fd42
Gecko: 42ef074f380f
Version: 28.0
status-b2g-v1.3: --- → affected
status-b2g-v1.4: --- → affected
Keywords: qawanted
(In reply to Jason Smith [:jsmith] from comment #2)
> I think the point the reporter is making is that you shouldn't be able to
> add the same contact twice, which seems valid. Why would you want the same
> contact showing in the to list three times in a row?

I've resolved as WONTFIX because we discussed this in the past and decided it would be a waste to add more code to check for this, and decided to not fix it.

Rationale is:
* it's easy to remove it if it was added accidentally
* if someone specifically adds the same contact twice, why would we prevent it?
* we don't show a phone number that's been already added in the suggestions list. As a result, the only ways to add the same contact twice is:
  + select it from the contact list after pressing the "+" icon
  + type the contact name exactly, then press ";" or ","
* edge cases:
  + what should happen if the user types the phone number of a contact he already added?
  + what should happen if the user chooses a different contact name, but with the same phone number?

For all these reasons, we keep the only consistent and safe approach: we don't try to guess what the user wants, and behaves according to what the user does. Which is what we do now.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → WONTFIX
Duplicate of this bug: 1019345
You need to log in before you can comment on or make changes to this bug.