[DHTML] Flickering dynamic menu

RESOLVED FIXED in mozilla1.2beta

Status

()

Core
Layout
P2
normal
RESOLVED FIXED
17 years ago
16 years ago

People

(Reporter: Markus Hübner, Assigned: Kevin McCluskey (gone))

Tracking

(4 keywords)

Trunk
mozilla1.2beta
x86
Windows 2000
dom0, perf, regression, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bae:2001121003], URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

17 years ago
For example move over "Solutions" then the menu-items will appear.
If you move down the whole list flickers.

This works fine in Opera, MSIE and also in Netscape 6.1 - so must be somehow 
regressed since then.

Using build 2001092503
(Reporter)

Updated

17 years ago
Keywords: mozilla0.9.5, regression

Comment 1

17 years ago
same for me on W2k 0.9.4+ (2001092308)
May have appeared before.
(Reporter)

Updated

16 years ago
Keywords: dom0

Comment 2

16 years ago
Appears to have regressed some time between 07-25 and 09-17 - needs more
narrowing, obviously.
(Reporter)

Comment 3

16 years ago
another terrible looking example is
http://www.gebr-weiss.com/
try for example "produkte" it's flickering heavily.

Keywords: mozilla0.9.6, nsCatFood
(Assignee)

Updated

16 years ago
Target Milestone: --- → mozilla1.0

Comment 4

16 years ago
http://www.nextra.com seems to only flicker when I move the mouse cursor as fast
as I can (without leaving the menu).

http://www.gebr-weiss.com/ on the other hand is causing flicker on each link on
the menu.

build 2001102903 win32

I think this is caused by the way mozilla reflows.

Markus: think you could create a very simple testcase?
(Reporter)

Comment 5

16 years ago
http://www.factiva.com/
[just move over "products", ....]
would be another example.

Updated

16 years ago
Status: NEW → ASSIGNED
Keywords: mozilla1.0

Updated

16 years ago
Blocks: 113492

Comment 6

16 years ago
build 2001120603 win32

oddly I don't see any flickering in this build with the 3 URLs

Comment 7

16 years ago
maybe I was testing it wrong.....

I don't see this problem all the time, just sometimes when I hover on the menus
real fast, and even then I'm not sure if I've left the menu and come back. It
might help to know when a onmouseover onmouseout event happens...

Comment 8

16 years ago
matic: could you create a really big menu for testing :-) ?
(Reporter)

Updated

16 years ago
Keywords: mozilla0.9.7, testcase
(Reporter)

Comment 9

16 years ago
Created a (big quite big) testcase :-) at
http://www.world-direct.com/mozilla-testcases/101698/nextra.htm

Comment 10

16 years ago
ok this is not a mozilla bug but a mozilla feature. The flickering occurs
because a mouseout on the DIV is being caused by mouseout events bubbling from
the elements in the DIV. I'll attach a testcase
Keywords: mozilla0.9.7, testcase

Comment 11

16 years ago
Created attachment 60941 [details]
testcase with enable/disable bubbling

Comment 12

16 years ago
the testcase is a "menu" of sorts. when you select disable bubbling the table in
the DIV captures all mouseout events and stops it from propagating to the DIV.

note that further optimisation can be done for onmouseover

now the curious thing is that it is not seen in NS6.1
matic: could you try my testcase in NS6.1?

Updated

16 years ago
Keywords: mozilla0.9.7, testcase

Comment 13

16 years ago
Created attachment 60943 [details]
better testcase with enable/disable bubbling
Attachment #60941 - Attachment is obsolete: true

Comment 14

16 years ago
Here are the results on my P2-350,  win98
- with bubbling enabled:
flickering with 2001120703, ns 6.2.1
no flickering with k-meleon 0.6

- with bubbling disabled:
no flickering on 2001120703, ns 6.2.1, k-meleon 0.6

Comment 15

16 years ago
The last testcase flickers a lot for me with w98 P2 at 350 MHz, Mozilla build
2001120603, and  0.9.6 IF bubbling is enabled. If I select to disable it then no
flicker happens.

Testing with K-meleon 0.6 then no flicker happens no matter if bubbling is
enabled or not.

Comment 16

16 years ago
WFM on Linux build id 2001120708 Athlon 1333 and Linux build id 2001120703 Duron
700, but i confirm on Win98 build id 2001120703 on the duron, latest Basic
testcase with bubble enabled, makes moz to flicker like mad on windows.

Comment 17

16 years ago
WFM on Mac OS 9 build id: 2001120604 PowerPC 233
No flicker produced with either bubbling enabled or disabled, moving the mouse
really fast :), produces the same effect.

Updated

16 years ago
Keywords: perf

Comment 18

16 years ago
In the testcase from:
------- Additional Comment #13 From _basic@yahoo.com 2001-12-08 10:54 -------

Created an attachment (id=60943)
better testcase with enable/disable bubbling

I can easily reproduce the flickering using the build from 2001121003 on win98, 
with bubbling enabled. When I ran the mouse over the links the flickering was 
quite apparent, running the mouse along the side border did not cause the 
flicker. Turning the disabling the bubbling caused the flickering to stop.
Whiteboard: [bae:2001121003]
(Reporter)

Updated

16 years ago
Keywords: mozilla0.9.8
(Reporter)

Updated

16 years ago
Keywords: nsbeta1
(Reporter)

Comment 19

16 years ago
Any news on this one?
(Assignee)

Comment 20

16 years ago
Moving to Moz1.1. nsbeta1-. Engineers are overloaded with higher priority bugs.
Keywords: nsbeta1 → nsbeta1-
Target Milestone: mozilla1.0 → mozilla1.1
Keywords: mozilla0.9.5, mozilla0.9.6, mozilla0.9.7, mozilla0.9.8
It sounds like this bug is really "onmouseout events bubble when they probably
shouldn't", which would be a DOM issue ... Fabian, care to comment?

Comment 22

16 years ago
http://www.w3.org/TR/2000/REC-DOM-Level-2-Events-20001113/events.html#Events-MouseEvent
mouseout
    The mouseout event occurs when the pointing device is moved away from an
element. This event is valid for most elements..
        * Bubbles: Yes
        * Cancelable: Yes

that's all I can say... If the bubbling is the _only_ cause of the flickering,
then this bug is probably invalid... The fact that it is a regression makes it
sound like there is another cause to this bug than the bubbling, though. Or
perhaps bubbling has been fixed since 6.1 (in which case it's an evangelism
bug). If someone could send a mail to joki about this, it would probably help.
(Reporter)

Updated

16 years ago
Keywords: mozilla1.0, nsbeta1- → mozilla1.1
(Reporter)

Comment 23

16 years ago
joki: what's your view on that?
(Reporter)

Comment 24

16 years ago
The flickering is causing a very visible annoyance.
If a fix isn't to difficult than this would be highly appreciated.
Keywords: mozilla1.1 → mozilla1.2
(Assignee)

Comment 25

16 years ago
the flicker on http://www.factiva.com/ is fixed by the patch in bug 163528
(Assignee)

Comment 26

16 years ago
I can not reproduce the flicker on http://www.gebr-weiss.com/ using a cvs trunk
build from this morning on WINXP
(Assignee)

Updated

16 years ago
Depends on: 163528
(Assignee)

Comment 27

16 years ago
Taking.
Assignee: attinasi → kmcclusk
Status: ASSIGNED → NEW
Priority: -- → P2
Target Milestone: mozilla1.1alpha → mozilla1.2beta
(Assignee)

Comment 28

16 years ago
Resolving as fixed since I do not see the flicker on http://www.factiva.com/ now
that my patch for bug 163528 has been checked in. I could not reproduce the
flicker on the other URL's listed in this bug.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.