Invitations sent via Exchange have skewed time information (1 hour off)

RESOLVED INVALID

Status

Calendar
E-mail based Scheduling (iTIP/iMIP)
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: Oliver, Unassigned)

Tracking

Lightning 2.6.5

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8430095 [details]
tb-exchange-calendar.png

User Agent: Opera/9.80 (Windows NT 6.1; WOW64) Presto/2.12.388 Version/12.15

Steps to reproduce:

I received a notification about a meeting from a colleague (trimmed for privacy reasons):

-----------------------
BEGIN:VCALENDAR
METHOD:REQUEST
PRODID:Microsoft Exchange Server 2010
VERSION:2.0
BEGIN:VTIMEZONE
TZID:UTC
BEGIN:STANDARD
DTSTART:16010101T000000
TZOFFSETFROM:+0000
TZOFFSETTO:+0000
END:STANDARD
BEGIN:DAYLIGHT
DTSTART:16010101T000000
TZOFFSETFROM:+0000
TZOFFSETTO:+0000
END:DAYLIGHT
END:VTIMEZONE
BEGIN:VEVENT
ORGANIZER;CN=...
ATTENDEE;ROLE=REQ-PARTICIPANT;PARTSTAT=NEEDS-ACTION;RSVP=TRUE;CN=...
DESCRIPTION;LANGUAGE=en-US:...
SUMMARY;LANGUAGE=en-US:...
DTSTART;TZID=UTC:20140528T110000
DTEND;TZID=UTC:20140528T120000
UID:...
RECURRENCE-ID;TZID=UTC:20140528T140000
CLASS:PUBLIC
PRIORITY:5
DTSTAMP:20140526T172650Z
TRANSP:OPAQUE
STATUS:CONFIRMED
SEQUENCE:2
LOCATION;LANGUAGE=en-US:...
X-MICROSOFT-CDO-APPT-SEQUENCE:2
X-MICROSOFT-CDO-OWNERAPPTID:-1466607650
X-MICROSOFT-CDO-BUSYSTATUS:TENTATIVE
X-MICROSOFT-CDO-INTENDEDSTATUS:BUSY
X-MICROSOFT-CDO-ALLDAYEVENT:FALSE
X-MICROSOFT-CDO-IMPORTANCE:1
X-MICROSOFT-CDO-INSTTYPE:3
X-MICROSOFT-DISALLOW-COUNTER:FALSE
BEGIN:VALARM
ACTION:DISPLAY
DESCRIPTION:REMINDER
TRIGGER;RELATED=START:-PT15M
END:VALARM
END:VEVENT
END:VCALENDAR
-----------------------

And I get to see what is hopefully attached after submitting.

This is on Windows 7, x64, latest patches and SPs applied. Thunderbird is version 24.5.0 and Lightning version 2.6.5 as mentioned above. I can provide other details on demand.

My timezone is set to "(UTC) Coordinated Universal Time" in the "Date and Time" settings. Note that this timezone has no DST whatsoever.

I wasn't able to locate the source code for Lightning, otherwise I'd have dug a bit deeper. But this is all I got for now.


Actual results:

See attachment.

I get to see that a meeting was scheduled for "2014-05-28 12:00 – 13:00", whereas the meeting was scheduled for one hour earlier, which can also be verified by checking the Base64-decoded contents, in particular:

DTSTART;TZID=UTC:20140528T110000
DTEND;TZID=UTC:20140528T120000


Expected results:

I would have expected to see the correct time, i.e.: "2014-05-28 11:00 – 12:00".

NB: this doesn't just affect the displayed time in the "message" itself, but also in the scheduled event.
(Reporter)

Comment 1

4 years ago
Oh, one more thing. The Thunderbird package I am using is en_US. Also found the Mercurial source repo.
(Reporter)

Comment 2

4 years ago
I'm sorry for the noise. A case of PEBKAC. For some reason beyond me the timezone (calendar.timezone.local) was set to Europe/London, which does - to my knowledge - observe DST. I reset that value to the default empty value using the config editor (not available in the combo box which offers time zones) and it seemingly behaves as expected now.

Should I file a defect report about UTC being unavailable from the combo box?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
Setting to empty should cause redetection of the timezone at the next startup. I'd suggest setting it to "UTC". Go ahead and file a bug to add UTC/Local Time to the prefs timezone dropdown.
You need to log in before you can comment on or make changes to this bug.