Closed Bug 1017052 Opened 6 years ago Closed 5 years ago

Desktop client needs ability to block a contact

Categories

(Hello (Loop) :: Client, defect, P1)

defect
Points:
2

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1038257
mozilla35

People

(Reporter: RT, Unassigned)

References

Details

(Whiteboard: [p=2, contacts][loop-uplift][first release needed][privacy needs this in the first release of contacts])

User Story

As a signed-in FF browser user I can block a particular contact, so that he can't call me anymore.

Attachments

(1 file)

This allows a registered user with a list of contacts to prevent a particular user from calling him.
Bug 1000142 allows a user to decide whether he wants to be called by anyone or his contacts only although if a Google contact starts spamming it will be complex for the user to (1) remove that user from the Google contacts and (2) re-sync the contacts with Google - both because of the complexity of the process and the fact that there are no obvious UX clues to achieve this.

This assumes that the black listing is handled on the client only with local storage of the information required to block a contact.
Darrin, can you update the UX to include the ability to block a contact? Not sure if we should allow that from the incoming call notification screen or from the contact list directly...
Flags: needinfo?(dhenein)
Flags: needinfo?(dhenein)
A contact should be blocked from the contact list as per attached mock-up from Darrin.
Attached image Block a contact
We need an indicator to notify the user that certain contacts are blocked, Darrin can you please update the UX?
Flags: needinfo?(dhenein)
Currently the MVP spec shows blocked contacts at the bottom of the list (so you can unblock them if needed)... I'm not sure if it should be here or in the preferences panel (presumably this is something (unblocking) that people wouldn't need to do that often...)
Flags: needinfo?(dhenein)
Thanks I can see that - looks good !
User Story: (updated)
Summary: Desktop client needs ability to prevent a contact from calling the user → Desktop client needs ability to block a contact
Blocks: 1021729
No longer blocks: 972015
Priority: P1 → P2
Whiteboard: p=? → [p=?, contacts]
Target Milestone: mozilla34 → mozilla35
Depends on: 1038716
I don't think this is needed for the first release of FxA & contacts.  Goes with bug 1021729.
Flags: firefox-backlog+
Whiteboard: [p=?, contacts] → [p=?, contacts][first release needed][privacy needs this in the first release of contacts]
Points: --- → 2
Priority: P2 → P3
Target Milestone: mozilla35 → mozilla34
Whiteboard: [p=?, contacts][first release needed][privacy needs this in the first release of contacts] → [p=2, contacts][first release needed][privacy needs this in the first release of contacts]
Priority: P3 → P1
Whiteboard: [p=2, contacts][first release needed][privacy needs this in the first release of contacts] → [p=2, contacts][loop-uplift][first release needed][privacy needs this in the first release of contacts]
Target Milestone: mozilla34 → mozilla35
Flags: qe-verify?
The implementation in bug 1038257 will make blocking and unblocking testable.
Depends on: 1038257
Flags: qe-verify? → qe-verify+
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1038257
This will be verified as part of bug 1038257.
Flags: qe-verify+ → qe-verify-
You need to log in before you can comment on or make changes to this bug.