bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

APK pre-gen task gets a 400 when fetching manifests

RESOLVED WONTFIX

Status

Marketplace
Integration
P2
normal
RESOLVED WONTFIX
4 years ago
2 years ago

People

(Reporter: kumar, Unassigned)

Tracking

x86
Mac OS X
Points:
---

Details

(Whiteboard: [marketplace-transition])

For some reason, the APK pre-generation task is getting a 400 response when fetching manifests (first seen after bug 1005984). These manifest URLs return 200s when I try them manually with curl.

Example:

PreGenAPKError: Error pre-generating APK for app 483932: Memorem at http://memorem.otaviorrossi.com/memorem/manifest.webapp; generator=https://controller.apk.firefox.com/application.apk (SSL cert ok?); HTTPError: 400 Client Error: Bad Request
http://sentry.mktmon.services.phx1.mozilla.com/mkt/marketplacefirefoxcom/group/6184/

$ curl -v http://memorem.otaviorrossi.com/memorem/manifest.webapp
...
< HTTP/1.1 200 OK

Lots of other examples, such as http://sentry.dmz.phx1.mozilla.com/marketplace-dev/marketplace-dev/group/19083/
looks like this is maybe a symptom of the generator getting overloaded: bug 1010382

Updated

4 years ago
Priority: -- → P2
whoops, my bad. This 400 is reproducible: bug 1017184

curl -v 'https://controller.apk.firefox.com/application.apk?manifestUrl=http://memorem.otaviorrossi.com/memorem/manifest.webapp'
...
< HTTP/1.1 400 Bad Request

Hmm, when there are repeated errors like this, Marketplace probably shouldn't keep trying to generate the APK
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
Whiteboard: [marketplace-transition]
You need to log in before you can comment on or make changes to this bug.