Can't select Console data in Web Developer

RESOLVED WONTFIX

Status

defect
P2
normal
RESOLVED WONTFIX
5 years ago
Last year

People

(Reporter: wolfy, Unassigned)

Tracking

(Blocks 1 bug)

29 Branch
x86
macOS
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [console-papercuts][polish-backlog])

Reporter

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140506152807

Steps to reproduce:

I used to be able to click in the console log area and press Command-A to select all of the text in the log and copy it elsewhere for analysis.  I no longer seem to be able to do this - the Edit, Select All option in the menus is also not working (though it isn't greyed out).


Actual results:

I clicked in the console log area, pressed Command-A. Nothing happened.


Expected results:

The entire console log should have been selected so I could copy it.

Updated

5 years ago
Component: Untriaged → Developer Tools: Console
Cmd-A in the console output pane doesn't work, but I don't remember why. CCing Mihai who would probably know. The menu options to select all and copy/paste work fine for me though, in both the context menu and app menu. Could you try to reproduce this in a clean profile to see whether some other add-on is interfering with the menus?
Reporter

Comment 2

5 years ago
Thanks for looking, Panos.

I tried, just now, with a clean profile and a totally vanilla account on my Mac - no dice.  No Cmd-A.  Copy and Select All on the Edit menu are grayed out.

Cmd-A has always worked for me until FF 29.  I use it regularly as sometimes it is easier to look at console output in a different viewer.

FWIW, I usually use the console log in detached window.  I don't know if Cmd-A worked while in attached mode, but right now it doesn't work in either mode.
Do you still see Select All and Copy grayed out if you click on the output pane first to focus it? Right clicking on the output pane and selecting Select All always works for me.
Reporter

Comment 4

5 years ago
I *can* Select All by right clicking - it works there.  Select All does not work from the main Firefox menu though.

I'm mostly happy being able to right click and select all at least (though it sometimes is helpful to me to be able to very quickly to a Command-A to select all).  Still kinda strange behavior though.
Whiteboard: [console-papercuts]
Whiteboard: [console-papercuts] → [console-papercuts][devedition-40]
Setting devedition-40 bugs to P2, filter on C17C996C-A0BE-4153-8057-FAB642D0746D
Priority: -- → P2
Jeff, I think we can WONTFIX this bug. 
The console behavior is that we focus the evaluation input by default, so that when you do CTRL+A, you select the input text. Now, we introduced "Select all" in console context menu...
And if you focus the console output area somehow (double click on text, slide to select text) CTRL+A is going to select all the output.
Flags: needinfo?(jgriffiths)
(In reply to Alexandre Poirot [:ochameau] from comment #6)
> Jeff, I think we can WONTFIX this bug. 
> The console behavior is that we focus the evaluation input by default, so
> that when you do CTRL+A, you select the input text. Now, we introduced
> "Select all" in console context menu...
> And if you focus the console output area somehow (double click on text,
> slide to select text) CTRL+A is going to select all the output.

Yeah, I think I agree. In particular I don't think we should select all console output if the focus is in a text input, ever.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Flags: needinfo?(jgriffiths)
Resolution: --- → WONTFIX
Whiteboard: [console-papercuts][devedition-40] → [console-papercuts][polish-backlog]

Updated

Last year
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.