Closed Bug 1017204 Opened 6 years ago Closed 6 years ago

[B2G][Homescreen][Everything.me]Brief wallpaper overlap displays between saved wallpaper and e.me search result page wallpaper when pop up keyboard vanishes

Categories

(Firefox OS Graveyard :: Gaia::Everything.me, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.4 affected, b2g-v2.0 affected)

RESOLVED DUPLICATE of bug 1017327
Tracking Status
b2g-v1.4 --- affected
b2g-v2.0 --- affected

People

(Reporter: mclemmons, Unassigned)

References

()

Details

(Whiteboard: [2.0-flame-test-run-1], [FT:System-Platform])

User has saved a wallpaper from a previous e.me search result. User searches for a different result to temporarily get the different wallpaper suggestion. While the keyboard disappears, the background wallpaper's bottom layer is visible as it appears the primary image takes time to resolve itself from the space above the pop up keyboard to once the keyboard vanishes. Video clip from Youtube demonstrates at the 1 minute mark. 

Prerequisites:
1. Have a saved wallpaper from a previous e.me search result (i.e. eeyore) 

Repro Steps:
1) Update a Flame to BuildID: 20140527040202
2) Search for subject (donkey), delete the last few letters from the word (i.e. key) and select donkey from suggestion bar
3) Closely observe the device screen

Actual:
Briefly user sees homescreen saved wallpaper bottom section, where the pop up keyboard was housed before resolution of the suggested wallpaper displays on entire screen.

Expected:
Wallpaper consistently shows full screen of the suggested wallpaper from search bar results.

Repro frequency: 5/5 – 100 percent 
Link to failed test case: none  
Attached: Video clip = https://www.youtube.com/watch?v=HYHvLAQNWDY, see 1 minute section of video for final results, no logcat attached due to existing issue with logcat and Flame device.
Update to Comment 0 - Environmental Variables for Flame

Environmental Variables: 
Device: Flame 2.0 MOZ
BuildID: 20140527040202
Gaia: 6a391274cd436f8f0d1fad2db8c6b4805703259c
Gecko: cbe4f69c2e9c
Version: 32.0a1
Firmware Version: v10G-2
User Agent: Mozilla/5.0(Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
This issue reproduces on Buri 2.0 following STR from Comment 0. Brief overlap of wallpapers appear.

Environmental Variables
Device: Buri 2.0 MOZ
BuildID: 20140527040202
Gaia: 6a391274cd436f8f0d1fad2db8c6b4805703259c
Gecko: cbe4f69c2e9c
Version: 32.0a1
Firmware Version: v1.2-device.cfg
User Agent: Mozilla/5.0(Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
This issue reproduces on Buri 1.4 following STR from Comment 0. Brief overlap of wallpapers appear.

Environmental Variables:
Device: Buri 1.4 MOZ
BuildID: 20140527000202
Gaia: 0542778892a294d224e75af4a76be5d42938bc90
Gecko: d583ae109f54
Version: 30.0
Firmware Version: v1.2-device.cfg
This issue reproduces on Flame Base Solo following STR from Comment 0. Brief overlap of wallpapers appear.

Environmental Variables:
Device: Flame Base MOZ
BuildID: 20140520094859
Gaia: a73235d23685e9898f40647cebd83b3fcbfd0117
Gecko:
Version: 28.0
Firmware Version: v10G-2
This issue repros on Flame 1.4 following STR from comment 0.

Device: Flame 1.4 MOZ
BuildID: 20140527000202
Gaia: 0542778892a294d224e75af4a76be5d42938bc90
Gecko: d583ae109f54
Version: 30.0
Firmware Version: v10G-2
User Agent: Mozilla/5.0(Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
Hi, mclemmons

I temporarily set this bug as a duplicate bug of Bug 1017327.
If you think it is inappropriate, please feel free to change the status or needinfo me.
Thanks for your help. Have a nice day! :)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1017327
Whiteboard: [2.0-flame-test-run-1] → [2.0-flame-test-run-1], [FT:System-Platform]
You need to log in before you can comment on or make changes to this bug.