[B2G][Flame][2.0][Facebook][Contact] After importing a Facebook contact with a company, the 'Company' field disappear on the contact edit mode.

RESOLVED DUPLICATE of bug 1018850

Status

Firefox OS
Gaia::Contacts
RESOLVED DUPLICATE of bug 1018850
4 years ago
4 years ago

People

(Reporter: YeojinC, Assigned: Jose Manuel Cantera)

Tracking

({regression})

unspecified
2.0 S3 (6june)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v1.4 unaffected, b2g-v2.0 affected)

Details

(Whiteboard: [2.0-flame-test-run-1] , URL)

Attachments

(5 attachments)

(Reporter)

Description

4 years ago
Created attachment 8430297 [details]
NoCompany_EditContact.png

Description:
After importing a Facebook contact with a compnay, the user is unable to edit the 'company' field on the contact edit mode. Also, the 'company' field is not displayed on the 'Add contact' screen.

Pre-Req: (Have at least one contact with a facebook profile linked - Before the facebook profile was linked, the contact should have a company name.) 

Repro Steps:
1) Update a Flame to BuildID: 20140527040202.
2) Open Contact app.
3) Select the contact with a Facebook profiled linked with a company name.
4) Select the edit icon on the upper right corner on the screen.
5) Observe the 'Company' field does not exist.
6) Return to the main screen on the Contact app, and select the '+' icon.
7) Observe the 'Company' field does not exist. 

Actual:
The 'Company' field is not displayed in any existing or new conatct edit mode. The user is unable to add or edit the Company information.

Expected:
The user is able to delete the company name of the contact with a Facebook profile linked. The 'Company' filed is available to add or edit on any existing or new contact.

--------------------------------------------------------------------------------------
2.0 Environmental Variables:
Device: Flame 2.0 MOZ
BuildID: 20140527040202
Gaia: 6a391274cd436f8f0d1fad2db8c6b4805703259c
Gecko: cbe4f69c2e9c
Version: 32.0a1
Firmware Version: v10G-2
User Agent: Mozilla/5.0 (Mobile; rv: 32.0) Gecko / 32.0 Firefox / 32.0


Repro frequency: 100%, etc.
Link to failed test case: https://moztrap.mozilla.org/manage/case/5181/
See attached: screenshot, logcat

---------------------------------------------------------------------------
This issue also occurs on Buri v2.0:

2.0 Environmental Variables:
Device: Buri v2.0 MOZ RIL
BuildID: 20140527040202
Gaia: 6a391274cd436f8f0d1fad2db8c6b4805703259c
Gecko: cbe4f69c2e9c
Version: 32.0a1
Firmware Version: V1.2-device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
(Reporter)

Comment 1

4 years ago
Created attachment 8430298 [details]
NoCompany_AddContact.png
(Reporter)

Updated

4 years ago
status-b2g-v1.4: --- → unaffected
status-b2g-v2.0: --- → affected
(Reporter)

Comment 2

4 years ago
The issue does NOT occur on the following devices/versions:


Buri 2.0

2.0 Environmental Variables:
Device: Buri v2.0 MOZ RIL
BuildID: 20140527040202
Gaia: 6a391274cd436f8f0d1fad2db8c6b4805703259c
Gecko: cbe4f69c2e9c
Version: 32.0a1
Firmware Version: V1.2-device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
=====================================================================

Buri 1.4

1.4 Environmental Variables:
Device: Buri 1.4 MOZ
BuildID: 20140521000202
Gaia: 93623f6435849cc9f54d9996e8e64828ac9091d1
Gecko: 12fe2b67a099
Version: 30.0
Firmware Version: v1.2-device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

==================================================================

Flame v10F-3

1.3 Environmental Variables:
Device: Flame 1.3
BuildID: 20140505215459
Gaia: ec462dc62979dae593b4ad96ac3851ccbafe1813
Gecko: Unknown
Version: 28.0
Firmware Version: v10F-3
User Agent: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0

====================================================================

Flame v10G-2

1.3 Environmental Variables:
Device: Flame 1.3
BuildID: 20140520094859
Gaia: a73235d23685e9898f40647cebd83b3fcbfd0117
Gecko: Unknown
Version: 28.0
Firmware Version: v10G-2
User Agent: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0
(Reporter)

Comment 3

4 years ago
Created attachment 8430315 [details]
logcat_20140528_MissingCompanyField.txt
Can we get a screenshot of what's seen on 1.4?
Keywords: qawanted
Created attachment 8430978 [details]
Facebook linked contact with a company (in edit mode)

Added picture of 1.4 Flame

Updated

4 years ago
Keywords: qawanted
QA Contact: ekramer
Sounds like we're missing UX here then...
blocking-b2g: --- → 2.0?
Keywords: regression, regressionwindow-wanted

Updated

4 years ago
blocking-b2g: 2.0? → 2.0+
(Assignee)

Comment 7

4 years ago
Created attachment 8432358 [details]
19863.html

regression from visual refresh ... 

Please take into account that this patch does not solve all visual problems with the edition of FB Contacts. I'm going to append a follow-up bug for that, to be solved during the TPE WW with the help of Arnau
Attachment #8432358 - Flags: review?(francisco)

Updated

4 years ago
Keywords: regressionwindow-wanted
Assignee: nobody → jmcf
Target Milestone: --- → 2.0 S3 (6june)
(Assignee)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1018850
(Assignee)

Updated

4 years ago
Attachment #8432358 - Flags: review?(francisco)
You need to log in before you can comment on or make changes to this bug.