Closed Bug 101725 Opened 21 years ago Closed 21 years ago

[RFE] Smart Download Manager

Categories

(SeaMonkey :: General, enhancement)

x86
Windows 2000
enhancement
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 25995

People

(Reporter: coffeebreaks, Assigned: asa)

Details

I've seen many suggestion regarding the downloads and there even a META tracking
bug 75364. Here's my suggestion: let's introduce a download manager window.

Downloading many things at a time creates many windows. We have many improvement
bugs for these windows. E.g. 
bug 35046 [RFE] Show download progress (%) in title when minimized 
bug 36776 [RFE] Show download progress in window icon 
bug 72982 Show download percentage complete in Windows taskbar  

Instead of having many windows for each download, I would prefer to have a
download manager.
Here's an example of how I could use it.
Each time I start downloading an item, it is added to the download manager
queue, which has a graphical UI with a table.
In this download manager, I could have several download groups. (I can see 4 for
now: High/normal/Limitated/Later). More would probably overkilling). 
The lower priority group would have a bandwitdh limit (This would solve the
'limit bandwidth for downloading' RFE I've seen somewhere but cannot find anymore)
The middle group will be normal downloading.

The High download group is for high priority download. When a download is in
that category all other current download.

An option to limit the current badnwitdh put all download in the low limit and
set the bandwidth.

The user will be able to decide to which group all new download will be part off.

Thanks to the UI, the user will be able to see/sort/pause/resume/cancel one or
manu download at a time. He could also for example schedule a downloading for later

In case of crash, persistence is implemented to remember the list. Persistence
probably only remembers the source and targets but not the settings for each
download. [Not that necessary]

Advantages of this method:
- one window.
- allow more complex functions (E.g. pause/resume many downloads at a time,
schedule, freeze all but one or two downloads)
- no need to implement some of the proposed RFE. Other fit better within the scheme.
- Restoring the state of downloadings will be easier


Drawbacks:
- big change in UI. 
- some people might want to look after a specific download. In this case, we
have to have a better warning mecanism for downloaded items.
- ???


I've put that bug in Browser-General. Triage?
Isn't this bug 25995 ?
Yes, yes it is.

*** This bug has been marked as a duplicate of 25995 ***
Status: UNCONFIRMED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
vrfy dupe
Status: RESOLVED → VERIFIED
[RFE] is deprecated in favor of severity: enhancement.  They have the same meaning.
Severity: normal → enhancement
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.