Camcorder preview and camcorder recording is not smooth when recording from messaging app for attachment. Sluggishness observed.

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Camera
RESOLVED WONTFIX
4 years ago
5 months ago

People

(Reporter: Leyla, Unassigned, NeedInfo)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(tracking-b2g:backlog)

Details

(Whiteboard: [caf priority: p2][CR 665602][perf-reviewed])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
8x25_v1.3_FFOS: Camcorder preview and camcorder recording is not smooth when recording from messaging app for attachment.

Steps:
1. launch Messaging App.
2. Tap on Compose new message icon.
3. Tap on Attachment icon.
4. Select Camera -> Switch to Camcorder.
5. Tap on Record icon.

Actual Result:
Camcorder preview and camcorder recording is not smooth when recording from messaging app for attachment. 

Sluggishness observed in both preview and recording.
(Reporter)

Updated

4 years ago
blocking-b2g: --- → 1.3?
We really need a video to see this behavior, and the device being used (8x25?)
Flags: needinfo?(lcelebi)
Helix is a 8x25
QA,

Please test on Open C.
Keywords: qawanted
(In reply to Michael Vines [:m1] [:evilmachines] from comment #2)
> Helix is a 8x25

Michael,

The production devices for 1.3 are Open C, Open 2, Sora. Helix is not being used in 1.3. We'll test to see if this reproducible on Open C to move ahead.
I've looked into this bug on OpenC on Base and 2.0 and don't seem to see any sluggishness when viewing the preview or recording within the messaging app. It would be helpful to have a reference video for this but just observing the behavior I'm seeing on the OpenC, I don't see the issue.
Keywords: qawanted
QA Contact: croesch
(In reply to Preeti Raghunath(:Preeti) from comment #4)
> (In reply to Michael Vines [:m1] [:evilmachines] from comment #2)
> > Helix is a 8x25
> 
> Michael,
> 
> The production devices for 1.3 are Open C, Open 2, Sora. Helix is not being
> used in 1.3. We'll test to see if this reproducible on Open C to move ahead.

That's not quite accurate.  We should talk offline
Partner has requested a 7x27a/8x25 upgrade to v1.3, affecting the following devices --  Helix (Huawei), Buri (TCL), Leo (LGE), Inari (ZTE Open).

QA

Please test with the devices above and record your findings. Working on getting a video as well.
Keywords: qawanted

Updated

4 years ago
QA Contact: croesch

Comment 8

4 years ago
(In reply to Preeti Raghunath(:Preeti) from comment #7)
> Partner has requested a 7x27a/8x25 upgrade to v1.3, affecting the following
> devices --  Helix (Huawei), Buri (TCL), Leo (LGE), Inari (ZTE Open).
> 
> QA
> 
> Please test with the devices above and record your findings. Working on
> getting a video as well.

Mozilla QA doesn't have these types of update scenarios.  Partner needs to own this because they generate and build the images themselves.    

We already cover n -> n+1; n->n+latest during the functional test pass.   But those are against mozilla generated builds.
Keywords: qawanted
(In reply to Tony Chung [:tchung] from comment #8)
> (In reply to Preeti Raghunath(:Preeti) from comment #7)
> > Partner has requested a 7x27a/8x25 upgrade to v1.3, affecting the following
> > devices --  Helix (Huawei), Buri (TCL), Leo (LGE), Inari (ZTE Open).
> > 
> > QA
> > 
> > Please test with the devices above and record your findings. Working on
> > getting a video as well.
> 
> Mozilla QA doesn't have these types of update scenarios.  Partner needs to
> own this because they generate and build the images themselves.    
> 
> We already cover n -> n+1; n->n+latest during the functional test pass.  
> But those are against mozilla generated builds.

Yes, partner will own their update process but i guess it will be safe if you could run a 1.1 to 1.3 update and be sure that the fault will be in partner side... otherwise the issue can be in Mozilla side because none had checked it.
(In reply to Tony Chung [:tchung] from comment #8)
> (In reply to Preeti Raghunath(:Preeti) from comment #7)
> > Partner has requested a 7x27a/8x25 upgrade to v1.3, affecting the following
> > devices --  Helix (Huawei), Buri (TCL), Leo (LGE), Inari (ZTE Open).
> > 
> > QA
> > 
> > Please test with the devices above and record your findings. Working on
> > getting a video as well.
> 
> Mozilla QA doesn't have these types of update scenarios.  Partner needs to
> own this because they generate and build the images themselves.    
> 
> We already cover n -> n+1; n->n+latest during the functional test pass.  
> But those are against mozilla generated builds.

We do support Buri though, so it is valid to ask for a testing request there. The others I don't think it's valuable to analyze however.

Can we test this on Buri 1.3?
Keywords: qawanted
Testing on Buri V1.3, I saw very acceptable video recording performance and camera preview through the messaging app. No noticeable lag or sluggishness.

Environmental Variables
Device:  Buri v1.3
Build ID: 20140603024001
Gecko: https://hg.mozilla.org/releases/mozilla-b2g28_v1_3/rev/560138f48a17
Gaia: 2408c2238254776b0d3716753b7bf917883c9915
Platform Version: 28.0
Firmware Version: v1.2-device.cfg
Keywords: qawanted
QA Contact: croesch
Without proof of this happening on a production device, I don't think we can block on this.
blocking-b2g: 1.3? → backlog

Updated

4 years ago
Whiteboard: [CR 665602] → [caf priority: p2][CR 665602]
Whiteboard: [caf priority: p2][CR 665602] → [caf priority: p2][CR 665602][perf-reviewed]

Comment 13

4 years ago
Created attachment 8438927 [details]
video_1017289.3gp

Comment 14

4 years ago
Please find the video attached for reference.
Flags: needinfo?(lcelebi)
This bug is quite old. Is this still an issue?
Flags: needinfo?(lcelebi)
(Assignee)

Updated

3 years ago
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog

Comment 16

5 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.