Add WoSign root certificates to NSS

RESOLVED FIXED in 3.16.3

Status

NSS
CA Certificates Code
--
enhancement
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Kathleen Wilson, Unassigned)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
This bug requests inclusion in the NSS root certificate store of the following certificates, owned by WoSign.

Friendly name: Certification Authority of WoSign
Certificate location: http://www.wosign.com/Root/WS_CA1_NEW.crt
SHA1 Fingerprint: B9:42:94:BF:91:EA:8F:B6:4B:E6:10:97:C7:FB:00:13:59:B6:76:CB
Trust flags: Websites, Email, Code Signing
Test URL: https://root1evtest.wosign.com/

Friendly name: CA 沃通根证书
Certificate location: http://www.wosign.com/Root/ws_ca2_new.crt
SHA1 Fingerprint: 16:32:47:8D:89:F9:21:3A:92:00:85:63:F5:A4:A7:D3:12:40:8A:D6
Trust flags: Websites, Email, Code Signing
Test URL: http://www.wosign.com/Root/ws_ca2_new.crt

This CA has been assessed in accordance with the Mozilla project guidelines, and the certificates approved for inclusion in bug #851435.

The next steps are as follows:

1) A representative of the CA must confirm that all the data in this bug is correct, and that the correct certificates have been attached.

2) A Mozilla representative creates a patch with the new certificates, and provides a special test version of Firefox.

3) A representative of the CA uses the test version of Firefox to confirm (by adding a comment in this bug) that the certificates have been correctly imported and that websites work correctly.

4) The Mozilla representative requests that another Mozilla representative review the patch.

5) The Mozilla representative adds (commits) the patch to NSS, then closes this bug as RESOLVED FIXED.

6) At some time after that, various Mozilla products will move to using a version of NSS which contains the certificates. This process is mostly under the control of the release drivers for those products.
(Reporter)

Comment 1

3 years ago
Created attachment 8430398 [details]
CertificationAuthorityofWoSign.crt
(Reporter)

Comment 2

3 years ago
Created attachment 8430399 [details]
CA沃通根证书.crt
(Reporter)

Comment 3

3 years ago
Richard,  Please see step #1 above.
(Reporter)

Comment 4

3 years ago
Correction to test URL of second cert...

Friendly name: CA 沃通根证书
Certificate location: http://www.wosign.com/Root/ws_ca2_new.crt
SHA1 Fingerprint: 16:32:47:8D:89:F9:21:3A:92:00:85:63:F5:A4:A7:D3:12:40:8A:D6
Trust flags: Websites, Email, Code Signing
Test URL: https://root2evtest.wosign.com
(Reporter)

Updated

3 years ago
Blocks: 1017299

Comment 5

3 years ago
(In reply to Kathleen Wilson from comment #3)
I found one error: the second root test URL is: https://root2evtest.wosign.com/
and please change the two root CA friendly name:
Root1: Certification Authority of WoSign       Friend name: WoSign
Root2: CA 沃通根证书                             Friendly name: WoSign China

And I confirm that the correct root certificates have been attached.

Thanks a lot!

Comment 6

3 years ago
Comment#4 corrected the test URL problem, thanks.

Updated

3 years ago
Blocks: 1021967

Updated

3 years ago
No longer blocks: 1021967
Depends on: 1021967

Comment 7

3 years ago
thanks, it works. But it don't display greenbar.
(Reporter)

Comment 8

3 years ago
(In reply to Richard Wang from comment #7)
> thanks, it works. 

Thanks for testing.


> But it don't display greenbar.

EV treatment (Bug #1017299) requires a different code change, and can only be done after the root has been included.

Comment 9

3 years ago
Thanks. When the root will been included?

Comment 10

3 years ago
fixed as part of bug 1021967
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → 3.16.3

Comment 11

3 years ago
I installed new FireFox 31 that I can't find my two root builtin, what's the problem? is it a bug? I tested English version and Chinese version. Please help, thanks.

Comment 12

3 years ago
It's not a bug.

Your root was added to NSS 3.16.3

The first Firefox version that will use it is Firefox 32.
You need to log in before you can comment on or make changes to this bug.