Closed Bug 1017327 Opened 6 years ago Closed 6 years ago

[B2G][Keyboard]Selecting the URL bar within Browser App to have the pop up keyboard appear briefly shows either the wallpaper background or black space

Categories

(Firefox OS Graveyard :: Gaia::System::Input Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.4 unaffected, b2g-v2.0 fixed)

VERIFIED FIXED
2.0 S4 (20june)
Tracking Status
b2g-v1.4 --- unaffected
b2g-v2.0 --- fixed

People

(Reporter: mclemmons, Assigned: timdream)

References

()

Details

(Keywords: regression, Whiteboard: [2.0-flame-test-run-1], [FT:System-Platform][p=3])

Attachments

(1 file, 1 obsolete file)

User has a URL within the URL bar and taps the URL bar to get the popup keyboard to appear. However, before its appearance, there is an area of either the wallpaper from the homescreen or black space. This is less than a second as the keyboard replaces this area. This does not occur on Flame 1.4 or Flame Base Solo.  

Prerequisites:
1. Open Browser App 
2. URL bar has a URL within it 

Repro Steps:
1) Update a Flame to BuildID: 20140527040202
2) Tap in URL field while observing device behavior

Actual:
An area of either the wallpaper from the homescreen or black space. This is less than a second as the keyboard replaces this area. 

Expected:
Graceful transition without black space or wallpaper residue. 

Notes:
Repro frequency: 5/5 – 100 percent 
Link to failed test case: None
Attached: Video clip = https://www.youtube.com/watch?v=FQ9ZBSG1Hd4 (demonstrates 5 successive repros)

Environmental Variables: 
Device: Flame 2.0 MOZ
BuildID: 20140527040202
Gaia: 6a391274cd436f8f0d1fad2db8c6b4805703259c
Gecko: cbe4f69c2e9c
Version: 32.0a1
Firmware Version: v10G-2
User Agent: Mozilla/5.0(Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
This issue does not reproduce on Flame 1.4 following STR from Comment 0. There is no demonstration of black space or wallpaper residue in testing.

Device: Flame 1.4 MOZ
BuildID: 20140527000202
Gaia: 0542778892a294d224e75af4a76be5d42938bc90
Gecko: d583ae109f54
Version: 30.0
Firmware Version: v10G-2
User Agent: Mozilla/5.0(Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
This issue does not reproduce on Flame Base Solo following STR from Comment 0. There is no demonstration of black space or wallpaper residue in testing.

Environmental Variables:
Device: Flame Base solo
BuildID: 20140520094859
Gaia: a73235d23685e9898f40647cebd83b3fcbfd0117
Gecko:
Version: 28.0
Firmware Version: v10G-2
Whiteboard: [2.0-flame-test-run-1] → [2.0-flame-test-run-1], [FT:System-Platform]
Barely noticeable, so I think this is minor.
Keywords: regression
Hi, Rudy and all,

I temporarily set Bug 1017204 as a duplicate bug of this bug.
If you think it is inappropriate, please change the status of bug 1017204.
Thanks all!
Duplicate of this bug: 1017204
This is a regression caused by my patch in bug 1013155. The keyboard app now calls resize() twice, sometimes during the transition, so the app is being incorrectly resized before the transition is completed.
Assignee: nobody → timdream
Status: NEW → ASSIGNED
Component: Gaia::Keyboard → Gaia::System::Input Mgmt
Whiteboard: [2.0-flame-test-run-1], [FT:System-Platform] → [2.0-flame-test-run-1], [FT:System-Platform][p=3]
Blocks: 1013155
Comment on attachment 8432098 [details] [review]
mozilla-b2g:master PR#19849

So I can keep patching the keyboard_manager.js, but I think it make sense to control the transition state in another cleaner module.

Arguably this is more risky for 2.0 branch so I am not going to force this into 2.0, but I personally is confident enough to say let's land this for 2.0, at worse we could do a 2.0-only backout if the regression turned out to be significant.

Rudy, I removed some tests in keyboard_manager_test.js which is no longer necessary or valid.

Alive, please review this patch (after your blocker queue and blocker review queue :'(). If that's too long I will ask Rudy for review. We should also talk about how to leverage some of the handling with app window in the future release.
Attachment #8432098 - Flags: review?(alive)
Attachment #8432098 - Flags: feedback?(rlu)
Comment on attachment 8432098 [details] [review]
mozilla-b2g:master PR#19849

Given the amount of requests to Alive I am asking Rudy to review this instead.
Attachment #8432098 - Flags: review?(rlu)
Attachment #8432098 - Flags: review?(alive)
Attachment #8432098 - Flags: feedback?(rlu)
Attachment #8432098 - Flags: feedback?(alive)
Comment on attachment 8432098 [details] [review]
mozilla-b2g:master PR#19849

r=me with some minor nits to be addressed.
Thanks and sorry again for the delay to review this.
Attachment #8432098 - Flags: review?(rlu) → review+
Comment on attachment 8432098 [details] [review]
mozilla-b2g:master PR#19849

I think this is a mid-term solution before we have keyboardWindow and let appTransitionController to replace the state machine. Rudy's review should be enough.
Attachment #8432098 - Flags: feedback?(alive)
I re-push the branch to address the review, but I ended up hitting the perma-red on Travis-CI today. Given the fact the previous merge also failed [1] on the same tests and the cause of the issue has already identified (see dev-gaia), I am merging my patch anyway.

master: https://github.com/mozilla-b2g/gaia/commit/dfb4d047bfdf8a98d0aa57bd86c4c724d0a4e50f

[1] https://travis-ci.org/mozilla-b2g/gaia/builds/26910228
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
sorry had to revert this changes for failing gaia ui tests like https://tbpl.mozilla.org/php/getParsedLog.php?id=41197554&tree=B2g-Inbound
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Note in comment#13 that this failed on Mac OSX, but passed on linux64 (hence how it passed on Travis).

I can see similar failures on Mac OSX/Gaia-Try for this pull.

The pattern between both appears to be a timing problem, and possibly this code is invalid now:
https://github.com/mozilla-b2g/gaia/blob/master/tests/python/gaia-ui-tests/gaiatest/apps/keyboard/app.py#L146
(In reply to Carsten Book [:Tomcat] from comment #13)
> sorry had to revert this changes for failing gaia ui tests like
> https://tbpl.mozilla.org/php/getParsedLog.php?id=41197554&tree=B2g-Inbound

Ah, timing issue. That's alright, I should have push to Try instead of relying on Travis-CI only :'(.

Given the risk of the patch I am going to write the minimal one for FL today, and move that patch to another bug.
Comment on attachment 8436643 [details] [review]
mozilla-b2g:master PR#20210

Rudy, can you review this *today* so it could make 2.0?
Attachment #8436643 - Flags: review?(rlu)
Comment on attachment 8436643 [details] [review]
mozilla-b2g:master PR#20210

r=me.

Sorry about not noticing the attribute that our tests depend on.
Attachment #8436643 - Flags: review?(rlu) → review+
Attachment #8432098 - Attachment is obsolete: true
I am waiting Travis-CI to turn green for my small patch... not sure if itself caused the trouble.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Keywords: leave-open
Resolution: --- → FIXED
Target Milestone: --- → 2.0 S3 (6june)
Target Milestone: 2.0 S3 (6june) → 2.0 S4 (20june)
Thanks everyone!
I cannot reproduce this bug on latest V2.0 build.

* Build Information:
 - Gaia      6aa07ea10420bd77f93d7415b5e34d89acc47a7e
 - Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/c83fdcf0b735
 - BuildID   20140611160205
 - Version   32.0a2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.