Closed Bug 1017356 Opened 7 years ago Closed 7 years ago

Graphic defect in Usage app Settings when Data use alert is turned off

Categories

(Firefox OS Graveyard :: Gaia::Cost Control, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v1.3 wontfix, b2g-v1.3T wontfix, b2g-v1.4 wontfix, b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED FIXED
2.0 S4 (20june)
Tracking Status
b2g-v1.3 --- wontfix
b2g-v1.3T --- wontfix
b2g-v1.4 --- wontfix
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: nhirata, Assigned: mai)

References

Details

Attachments

(4 files)

Attached image 2014-05-28-18-38-04.png
1. launch cost control
2. go through FTU
3. select settings
4. turn Data use alert off if you haven't

Expected: no graphic defect
Actual: slight graphic defect

See screenshot.

Gaia      303e375a1b4c721984dcb68dfca24d6f50c291f2
Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/fcabeab5ebec
BuildID   20140528175422
Version   28.1
ro.build.version.incremental=eng.cltbld.20140528.172420
ro.build.date=Wed May 28 17:24:26 EDT 2014
Tarako
Turns out it's not Tarako specific.

Gaia      0ce948e378cab7ed3db20231281dd7ca2eb99779
Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3/rev/ce0dd450bffb
BuildID   20140528024003
Version   28.0
ro.build.version.incremental=324
ro.build.date=Thu Dec 19 14:04:55 CST 2013
Buri
Summary: [Tarako] graphic defect in Usage app Settings when Data use alert is turned off → Graphic defect in Usage app Settings when Data use alert is turned off
Hi Naoki, 
I don't understand what is the defect on the graphic would you mind attaching a graphic screenshot?

Regards
Flags: needinfo?(nhirata.bugzilla)
Marina, the screenshot is attached, I screenshoted the graphic issue.

This isn't consistent with the rest of the UI for Gaia.
Flags: needinfo?(nhirata.bugzilla)
Flags: needinfo?(firefoxos-ux-bugzilla)
Flagging Eric as we have no one on Cost Control, specifically. But yes, I see the graphic issue Naoki points out in the screenshot, which is inconsistent with the rest.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(epang)
Attached file proposal v1.0
Hi, 
would you mind give me your feedback?
Regards
Attachment #8440896 - Flags: feedback?(nhirata.bugzilla)
Attachment #8440896 - Flags: feedback?(epang)
Assignee: nobody → mri
(In reply to marina rodríguez [:mai] from comment #5)
> Created attachment 8440896 [details] [review]
> proposal v1.0
> 
> Hi, 
> would you mind give me your feedback?
> Regards

Hi Marina,

Looks like the disabled state of the button is incorrect.  If you go toe 'lists' at http://buildingfirefoxos.com/building-blocks/buttons.html you'll see the correct styling.

The background of the button shouldn't change and the styling of the button should use the building blocks.  

If you have any questions NI me :). Thanks!
Flags: needinfo?(epang)
Updated the PR, Epang would you mind reviewing again?
Flags: needinfo?(epang)
Duplicate of this bug: 1000779
Comment on attachment 8440896 [details] [review]
proposal v1.0

Much better!  Lots of things to fix in cost control.. but one bug at a time gets us closer. + from me, thanks for working on this Marina :)
Attachment #8440896 - Flags: feedback?(epang) → feedback+
Flags: needinfo?(epang)
Comment on attachment 8440896 [details] [review]
proposal v1.0

HI Salva, 
would you mind reviewing the patch?
Regards
Attachment #8440896 - Flags: review?(salva)
Comment on attachment 8440896 [details] [review]
proposal v1.0

The patch is ok but try removing the style completely. If it works, I prefer to remove styles.
Attachment #8440896 - Flags: review?(salva) → review+
MAster: 6ceaa60ca02f5ac704f28966d1c0b8fe71b21b58
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Attachment #8440896 - Flags: feedback?(nhirata.bugzilla)
Duplicate of this bug: 1036748
Duplicate of this bug: 1042522
Comment on attachment 8440896 [details] [review]
proposal v1.0

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

Changes on a css file to adapt the app to the visual refresh for 2.0
[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Feature
[User impact] if declined: not following visual refresh targeted for 2.0
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]:
Attachment #8440896 - Flags: approval-gaia-v2.0?(release-mgmt)
(In reply to marina rodríguez [:mai] from comment #15)
> Comment on attachment 8440896 [details] [review]
> proposal v1.0
> 
> NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to
> better understand the B2G approval process and landings.
> 
> Changes on a css file to adapt the app to the visual refresh for 2.0
> [Approval Request Comment]
> [Bug caused by] (feature/regressing bug #): Feature
> [User impact] if declined: not following visual refresh targeted for 2.0
> [Testing completed]: yes
> [Risk to taking this patch] (and alternatives if risky): low
> [String changes made]:

We are past the timeline of taking any non-blocking changes on 2.0 but I am making an exception here given the low risk, old approval request and more importantly due to the visual refresh revamp on 2.0.

If this causes any regressions, please back this out immediately.
Attachment #8440896 - Flags: approval-gaia-v2.0?(release-mgmt) → approval-gaia-v2.0+
This issue has been successfully verified on Flame 2.1, 2.0
See attachment:verify.png
Reproducing rate: 0/5

flame2.1 new build:
Gaia-Rev        5655269098c7e82254e56933f1af05b4abe2a2f3
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/86608c9389b5
Build-ID        20141204001201
Version         34.0

Flame 2.0 versions:
Gaia-Rev        8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/ff1100ba2ab8
Build-ID        20141204000228
Version         32.0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.