[Flame][v1.4][Wifi]There is no respondence about 10s when turn off and turn on WI-FI in quick tool bar(pull down notification bar).

RESOLVED DUPLICATE of bug 1009725

Status

Firefox OS
Wifi
RESOLVED DUPLICATE of bug 1009725
4 years ago
4 years ago

People

(Reporter: greatwall2686, Assigned: vchang)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.3 affected)

Details

(Whiteboard: torch)

Attachments

(1 attachment)

110.01 KB, application/x-rar
Details
(Reporter)

Description

4 years ago
Created attachment 8430484 [details]
turn on wifi.rar

* Description:
  Connected a Wi-Fi ap, pull down the notification bar and tap wifi icon to turn off, tap it again, you will find no respondence about 10s.
  Attach the log and occurrence time:10:25 am.

* Reproduction steps:
  1. Enter Settings view
  2. Select a wifi to connect
  3. Pull down notification bar.
  4. Tap wifi icon to turn off and tap it again to turn on
  

* Expected result:
  User can turn on wifi quickly after turning it on at quick settings bar(HTC one x+ about 1~2 s).

* Actual result:
  There is no respondence about 10s.
  This bug also happen in Settings->Wi-Fi

* Reproduction build:(Buri - Firefox OS V1.4 inside)
 - Gaia      17b102ee8d9a724b62285547cc5f1c5d30bfb01c
 - Gecko     https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/95be84248033
 - BuildID   20140520000201
 - Version   30.0

* Reproduction Frequency
  - 100%
QA Wanted to see if this reproduces on 1.3.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: qawanted
I've verified that I can repro this on the OpenC v1.3 base. However I can only get it to occur when Data is also enabled. Without Data enabled, I could not repro the wifi issue.

In the notification window I turned the wifi off and on about 4 times with no problems until the 5th try. The wifi button was grayed out in the off position for about 10-12 seconds and was not responding to attempts to turn it on. Eventually wifi button became available to turn back on.

Environmental Variables
Device: OpenC V1.3 Base
Build ID: 20140505052400
Gecko: /rev/
Gaia: Unknown Git commit; build date shown her
Platform Version: 28.0
Firmware Version: P821A10v1.0.0B06_LOG_DL
status-b2g-v1.3: --- → affected
Keywords: qawanted
QA Contact: croesch
(Assignee)

Updated

4 years ago
Assignee: nobody → vchang

Updated

4 years ago
Duplicate of this bug: 1020604
(Assignee)

Comment 4

4 years ago
I think this is duplicated of Bug 1009725. Since it's already a 1.4 blocker, let's fix the bug there.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1009725
You need to log in before you can comment on or make changes to this bug.