data manager focuses on first non-empty tab instead of password tab when 'passwords only' filter is applied

UNCONFIRMED
Unassigned

Status

SeaMonkey
Passwords & Permissions
UNCONFIRMED
4 years ago
4 years ago

People

(Reporter: lvm, Unassigned)

Tracking

SeaMonkey 2.26 Branch
x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:29.0) Gecko/20100101 Firefox/29.0 SeaMonkey/2.26 (Beta/Release)
Build ID: 20140428215944

Steps to reproduce:

1. open tools->password manager->manage stored passwords
2. type [a part of] a domain namel into the search box, this domain should also have other types of information stored e.g. cookies.


Actual results:

1. generic data manager is opened with no filter applied (All data types)
2. domain is found, the first non-empty tab is opened (e.g. cookies)


Expected results:

1. data manager should've opened with 'Passwords only' filter applied
2. passwords tab should've opened. Seamonkey opens the first non-empty tab instead of the passwords tab even if the 'Passwords only' filter is applied manually.

Comment 1

4 years ago
DUP of Bug 903865 - Preferences, Managed Stored Passwords does not set Filter Passwords Only in Data Manager
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 903865
(Reporter)

Comment 2

4 years ago
This bug actually contains two separate problems, the first one is that 'passwords only' filter is not applied automatically and it is indeed the subject of the bug 903865, sorry - missed it. The second one is that even when 'passwords only' filter is applied data manager still focuses on irrelevant tabs - cookies and preferences and it is not in scope of 903865. I changed the summary accordingly.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Summary: password manager invocation is muddled → data manager focuses on first non-empty tab instead of password tab when 'passwords only' filter is applied
You need to log in before you can comment on or make changes to this bug.