[Sora][Wi-Fi]DUT will disconnect the AP auto

RESOLVED INVALID

Status

Firefox OS
Wifi
P1
normal
RESOLVED INVALID
4 years ago
3 months ago

People

(Reporter: sync-1, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified

Firefox Tracking Flags

(tracking-b2g:backlog)

Details

(Whiteboard: [closeme 6/7/2014])

Attachments

(6 attachments)

582.25 KB, application/octet-stream
Details
97.30 KB, application/octet-stream
Details
70.81 KB, application/octet-stream
Details
38.82 KB, application/octet-stream
Details
131.19 KB, application/octet-stream
Details
255.48 KB, application/octet-stream
Details
(Reporter)

Description

4 years ago
Mozilla build ID:20140422024003
 Created an attachment (id=720980)
 refer the attachment
 
 DEFECT DESCRIPTION:
  DUT will disconnect the AP auto .Then it will connect the same AP auto.
 
  REPRODUCING PROCEDURES:
  1,connect the AP -> surf the internet ->DUT will disconnect the AP auto .Then it will connect the same AP auto.-> KO
(Reporter)

Comment 1

4 years ago
Created attachment 8430551 [details]
0527 new log
(Reporter)

Comment 2

4 years ago
Created attachment 8430552 [details]
0524 NEW log
(Reporter)

Comment 3

4 years ago
Created attachment 8430553 [details]
0527_new log2
(Reporter)

Comment 4

4 years ago
Created attachment 8430554 [details]
MMS&Wi-Fi disconnect
(Reporter)

Comment 5

4 years ago
Created attachment 8430555 [details]
auto close
(Reporter)

Comment 6

4 years ago
Created attachment 8430556 [details]
refer the attachment

Comment 7

4 years ago
We find that gecko issue "disconnect" and "reassociate" command to supplicant. 
Can you check whether it is ok?

Comment 8

4 years ago
When can't get dhcp info once, gecko will issue "disconnect" and "reassociate", Is this necessary?

Comment 9

4 years ago
Dears,

It's IOT blocker.
blocking-b2g: --- → 1.3?
I'm confused on the STR here. Can you rephrase the STR here? I don't understand how to test this.
Flags: needinfo?(sync-1)
(In reply to Jason Smith [:jsmith] from comment #10)
> I'm confused on the STR here. Can you rephrase the STR here? I don't
> understand how to test this.

I believe the STR is as following:

1. Connect to some Wifi AP
2. Surf the net for a while
3. Suddenly the Wifi will disconnect from the AP
4. And it will connect to that AP again after a while.

Could we have QA to test this issue? Suggest to surf the net for at least 10 minutes.

Thanks
Flags: needinfo?(sync-1)
QA Wanted for comment 11
Keywords: qawanted
(In reply to Wang Rong from comment #8)
> When can't get dhcp info once, gecko will issue "disconnect" and
> "reassociate", Is this necessary?

There is a retry count when dhcp info is not available. 
http://dxr.mozilla.org/mozilla-central/source/dom/wifi/WifiWorker.js?from=wifiworker.js&case=true#631
Please turn on wifi debug log in settings/developer/Wi-Fi output in ADB when reproducing the problem.

Comment 15

4 years ago
(In reply to Vincent Chang[:vchang] from comment #13)
Yes, I noticed that. do we must disconnect and reassociate when dhcp info is not available?
And can we get the reason why dhcp info is not available in the log?
(In reply to Vance Chen [:vchen][vchen@mozilla.com] from comment #11)
> I believe the STR is as following:
> 
> 1. Connect to some Wifi AP
> 2. Surf the net for a while
> 3. Suddenly the Wifi will disconnect from the AP
> 4. And it will connect to that AP again after a while.
> 
> Could we have QA to test this issue? Suggest to surf the net for at least 10
> minutes.

Followed steps and surfed the net (news.google.com and maps.google.com) for 15 minutes and did not encounter any wifi disconnection.

Tested on:
Device: Buri MOZ
BuildID: 20140530024008
Gaia: 5bd226b03a2d63dfe9df204f7c0afb9984e8fd42
Gecko: 57cd741e4d0b
Version: 28.0
Firmware Version: v1.2-device.cfg
User Agent: Mozilla/5.0 (Mobile; rv28.0) Gecko/28.0 Firefox/28.0
Keywords: qawanted
Can't block on something we can't reproduce.
blocking-b2g: 1.3? → backlog
Whiteboard: [closeme 6/7/2014]
(Assignee)

Updated

3 years ago
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
link all Fire C (codename: Sora) bugs to a meta one.
Blocks: 1258646

Updated

3 months ago
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.