Closed Bug 1017427 Opened 6 years ago Closed 5 years ago

Video overlay cut off after panning

Categories

(Firefox for Android :: Toolbar, defect)

Other
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
firefox31 --- unaffected
firefox32 --- verified
firefox33 --- verified
firefox34 --- fixed
firefox35 --- unaffected
fennec 32+ ---

People

(Reporter: blassey, Assigned: cwiiis)

References

()

Details

(Keywords: regression)

Attachments

(2 files, 3 obsolete files)

To reproduce, pan down such that the URL bar is of the screen and the video I'd in the middle if the screen. Then pan back up so that the URL bar reappears. As the URL bar cubes into view the play button on the visit gets cut off (revealing the video poster underneath) and the bottom of the video becomes black. This looks to be exactly the height of the URL bar, suggesting some offset isn't being honored.
Sounds like bug 955885 (filed by you) which was duped to bug 943206 and that was closed INVALID.
(In reply to Mark Finkle (:mfinkle) from comment #2)
> Sounds like bug 955885 (filed by you) which was duped to bug 943206 and that
> was closed INVALID.

No, this is different. You scroll the page and the layers are getting clipped incorrectly. In bug 955885 non-scrollable layers were getting scrolled.
Chris & Kats, do you know of any recent changes that would cause this?
Flags: needinfo?(chrislord.net)
Flags: needinfo?(bugmail.mozilla)
Maybe bug 1006797 or 1001438?
Flags: needinfo?(bugmail.mozilla)
Attached patch maybe-fix-video-clipping (obsolete) — Splinter Review
Does this fix the issue? (or if it makes it worse, does it fix the issue if you change offset.x, offset.y to -offset.x, -offset.y?)
Flags: needinfo?(chrislord.net) → needinfo?(blassey.bugs)
tracking-fennec: ? → 32+
Flags: needinfo?(blassey.bugs)
I'll note that you need to have flash disabled to see this bug, otherwise that video element is replaced by a flash video.
Attached patch offset_fix.patch (obsolete) — Splinter Review
Attachment #8431155 - Flags: review?(chrislord.net)
Assignee: nobody → chrislord.net
Attachment #8430856 - Attachment is obsolete: true
Attachment #8431155 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #8431155 - Flags: review?(chrislord.net)
Attachment #8432420 - Flags: review?(nical.bugzilla)
Attachment #8432420 - Flags: review?(nical.bugzilla) → review+
Obvious error fixed and pushed to inbound:

https://hg.mozilla.org/integration/mozilla-inbound/rev/07a74e6e53b2
Duplicate of this bug: 1020279
This restores how it was done before and hopefully doesn't upset reftests. (submitting now)
Attachment #8432420 - Attachment is obsolete: true
Attachment #8436947 - Flags: review?(nical.bugzilla)
Attachment #8436947 - Flags: review?(nical.bugzilla) → review+
https://hg.mozilla.org/mozilla-central/rev/1c213218173f
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 33
I'm not able to reproduce this anymore on Nightly 33.0a1 (2014-06-18) using Motorola Razr (Android 4.0.4) and Nexus 10 (Android 4.4.2), but the issue is reproducible on Aurora 32.0a2 (2014-06-18). 
Will this be uplifted to Aurora?
Comment on attachment 8436947 [details] [diff] [review]
Fix CompositorOGL render offset not offsetting clipping rect v2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): See bug description
User impact if declined: Unexpected behaviour
Testing completed (on m-c, etc.): Been on m-c for a while
Risk to taking this patch (and alternatives if risky): Low
String or IDL/UUID changes made by this patch: None
Attachment #8436947 - Flags: approval-mozilla-aurora?
Comment on attachment 8436947 [details] [diff] [review]
Fix CompositorOGL render offset not offsetting clipping rect v2

Aurora approval granted.
Attachment #8436947 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
The video is displayed correctly, no black portion at the bottom of the video after panning. So,
Verified fixed on:
Device: LG Nexus 4
OS: Android 4.4.2
Build: Firefox for Android 32.0a2 (2014-07-02)
Status: RESOLVED → VERIFIED
Backout out by bug 1046017 comment 51, because it blocks bug 1006797.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
tracking-fennec: 32+ → ?
Target Milestone: Firefox 33 → ---
Technically this is still fixed because the bug that causes this (1006797) was backed out along with this.
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
tracking-fennec: ? → 32+
You need to log in before you can comment on or make changes to this bug.