High CPU usage on new Nightly builds

RESOLVED WORKSFORME

Status

()

Core
General
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: Tasos Sahanidis, Unassigned)

Tracking

32 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8430764 [details]
Cpu usage comparison

Running latest Nightly causes 100% cpu usage on the core/thread.
Last build without this issue is the 2014-05-22 one, every other build after this one seems to be affected.
System is running Ubuntu 14.04 with 16GB of RAM and an AMD FX 8350 processor with the latest AMD Radeon fglrx graphics drivers (14.4).
Both parts of the screenshot have been taken after nightly is done loading the tabs and idling.
On the left part of the attached screenshot the high cpu usage can be seen, RAM and CPU usage gets lowered only because it was closed in the end to show the difference. If it kept running it would be doing the same.
On the right side is the old build running with the same profile, same configuration, same tabs open but the cpu usage is at normal levels.
This was done with about 274 tabs open (but not loaded since it was restarted).
I also tried with a clean profile which did not give clear results as the usage seems to be affected by the number of tabs opened and not whether they are loaded or not.
I tried disabling all of the addons in the current profile but it didn't fix anything.
Leaving 86 tabs open reduces the usage but it is still not as low as the one from the previous build.

Comment 1

4 years ago
This happens on windows version too, my guess is the changes in javascript engine which has more aggressive GC is causing the problem
Can you attach a profile, please?
Flags: needinfo?(tatokis)

Comment 3

4 years ago
Opening heavy script sites will cause the problem, even in clean profile.
e.g. facebook, google plus, gmail, google docs
If you have them opened for a few minutes, the CPU usage will start to surge.
I have a number of sites like that open right now and I'm not seeing any particular CPU usage.  Hence the request for a profile (which you can do in a nightly, without restarting it), to see what issue _you_ are seeing
(Reporter)

Comment 5

4 years ago
I have been testing new nightly builds for the past few days and Nightly seems to idle at 0% according to system monitor, instead of 12% like previously.
So this can be marked as resolved.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(tatokis)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.