Closed Bug 1017582 Opened 6 years ago Closed 6 years ago

Refine toast behaviour for Undo Close Tab

Categories

(Firefox for Android :: General, defect)

31 Branch
x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1015421

People

(Reporter: ibarlow, Unassigned)

References

Details

When you close a bunch of tabs in a row, things get kinda funky. We seem to display the toast after a slight delay, and for a set period of time. This means that if you close a bunch in a row, you end up with this stream of toasts that hang around long after you're done your task. I attached a movie here (sorry for the shaky cam, holding a tablet in one hand and demoing the interaction with the other is hard)

I'm not sure what the best approach to fix this would be, but I imagine replacing the most recent tab toast as soon as a new tab is closed would be a good start toward making this feel more right.
Doh, attachment didn't work. Here's the video http://cl.ly/0K2A2h0o0U3R
Doh!
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1015421
You need to log in before you can comment on or make changes to this bug.