Closed Bug 1017608 Opened 7 years ago Closed 7 years ago

Closing a bunch of tabs quickly results in many toasts that take a while to get through

Categories

(Firefox for Android Graveyard :: General, defect)

All
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1015421

People

(Reporter: kats, Unassigned)

Details

Open 6-7 tabs (about:home is fine). Open the tab tray and quickly close all of them. Observe how for each tab closed there is a toast that appears, but each toast takes a few seconds to go away and they are shown serially. After closing 6 tabs I have to wait over 10 seconds for the progression of toasts to go away. This is slightly annoying - maybe instead of toasts we can put something in the tab tray itself?
Or maybe after you close the second tab the toast changes from "Close <title> | undo" to "Closed 2 tabs | undo" and that multi-tab-undo-closed-tab toast can bring up a "which tab(s) would you like to reopen" dialog
I'm going to dupe this to bug 1015421, which should make the timing issue better. I like Brad's idea, but I wonder if that might be more appropriate in the context of a "close all tabs" interaction.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1015421
(In reply to Brad Lassey [:blassey] (use needinfo?) from comment #1)
> Or maybe after you close the second tab the toast changes from "Close
> <title> | undo" to "Closed 2 tabs | undo" and that multi-tab-undo-closed-tab
> toast can bring up a "which tab(s) would you like to reopen" dialog

To do that, we would actually need to store more tabs. Right now we only store one at a time. However, that will change with bug 1004850.
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.