M1RC1 N622 Trunk crash closing mail [@ nsSocketBS::GetTransport]

VERIFIED DUPLICATE of bug 123097

Status

P1
critical
VERIFIED DUPLICATE of bug 123097
18 years ago
10 years ago

People

(Reporter: greer, Assigned: mscott)

Tracking

({crash, qawanted, topcrash})

Trunk
mozilla0.9.9
x86
Linux
crash, qawanted, topcrash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

18 years ago
From the stack signature and the comments I'm taking a stab at the component. 
Reassign if I have sent it here in error. Has anyone seen this behavior of a 
crash on closing messenger?

Stack Trace: 

         nsSocketBS::GetTransport()
         nsSocketBS::ReleaseSocket()
         nsSocketBOS::Write()
         nsImapProtocol::TellThreadToDie()
         nsImapIncomingServer::CloseCachedConnections()
         nsMsgAccountManager::closeCachedConnections()
         _hashEnumerate__FP11PLHashEntryiPv()
         PL_HashTableEnumerateEntries()
         nsHashtable::Enumerate()
         nsMsgAccountManager::CloseCachedConnections()
         nsMsgAccountManager::Shutdown()
         nsMsgAccountManager::Observe()
         nsObserverService::Notify()
         NS_ShutdownXPCOM()
         main()
         libc.so.6 + 0x1d26e (0x4048f26e)     

M094 comments:
     (35780817) Comments: Pressed File->Quit  when I was reading email.
     (35756051) Comments: I've clicked the File-> Quit option  I was reading 
email.
     (35674847) URL: www.uol.com.br/aurelio
     (35466560) Comments: Closing Messanger (and the whole mozilla)
     (35455731) Comments: Closing it.
     (35455717) Comments: Closing it. File->Exit

Trunk comment:
MozillaTrunk Build: 2001092017 
Crash date: 2001-09-24
Platform: Linux 2.4.7
     (35825864) closing the program. I closed all my browser windows; lastly I 
closed my email window. I have 3 secure imap accounts tied to mozilla.
(Reporter)

Updated

18 years ago
Keywords: crash, qawanted, topcrash

Comment 1

17 years ago
I'm having trouble accessing talkback right now to see if this is still
occurring on recent builds.  Since it's a topcrash I'm changing the milestone
and the priority.  If someone has new information on this on 0.9.5 and later
builds, please update.
Priority: -- → P1
Target Milestone: --- → mozilla0.9.6

Comment 2

17 years ago
I was finally able to access talkback. This is still happening on 10/7 builds
with the same stack trace.

Updated

17 years ago
Keywords: nsbeta1

Updated

17 years ago
Keywords: nsbeta1 → nsbeta1+

Updated

17 years ago
Target Milestone: mozilla0.9.6 → mozilla0.9.7
(Assignee)

Comment 3

17 years ago
Looks like this is still happening (linux only) as late as 12/01 builds. Nothing
since 12/01 though. 
(Assignee)

Comment 4

17 years ago
actually I misread the date. We have a ton of copies of this stack trace on
linux all the way up until 11/20/01. Then it goes away. I know we had some leak
problems were transports weren't getting closed that was fixed around then.
Maybe that caused this to go away. 

Due to the fact that we saw it show up so regularly before and we haven't had a
single report sine the 20th of November, I'm going to mark this as fixed and
we'll keep an eye out to see if it pops up again. 
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 5

17 years ago
reopening.  I checked talkback (because of a bug I'm about to mark as a dup) and
it looks like this occurred throughout December and has a crash as recent as the
1/5 build.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla0.9.7 → mozilla0.9.9

Comment 6

17 years ago
*** Bug 116732 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 7

17 years ago
Scott, I just did a search in the Talkback DB for signatures containing 
"nsSocketBS::GetTransport". The latest buildID returned was 2001-12-21-08 (same 
as that in duped bug 116732). 

Where did you see a crash from a 20020105xx build?
(Assignee)

Comment 8

17 years ago
reclosing unless putterman can show a more recent stack trace. Neither greer nor
I are seeing a recent report in talkback. 
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 9

17 years ago
Reopening again...there are quite a few of these crashes reported for M099:

nsSocketBS::GetTransport   37
		 101765 	 RESO 	 FIXE 	 mscott@netscape.com 	 mozilla0.9.9 	 2002-01-22 
BBID range: 4848314 - 5201567
Min/Max Seconds since last crash: 4 - 450024
Min/Max Runtime: 1368 - 1026193
Crash data range: 2002-04-05 to 2002-04-14
Build ID range: 2002031008 to 2002031312
Keyword List : 
Stack Trace: 

	 nsSocketBS::GetTransport()
	 nsSocketBS::ReleaseSocket()
	 nsSocketBOS::Write()
	 nsImapProtocol::TellThreadToDie()
	 nsImapIncomingServer::CloseCachedConnections()
	 nsMsgAccountManager::closeCachedConnections()
	 _hashEnumerate__FP11PLHashEntryiPv()
	 PL_HashTableEnumerateEntries()
	 nsHashtable::Enumerate()
	 nsMsgAccountManager::CloseCachedConnections()
	 nsMsgAccountManager::Shutdown()
	 nsMsgAccountManager::Observe()
	 nsObserverService::NotifyObservers()
	 NS_ShutdownXPCOM()
	 main()
	 libc.so.6 + 0x1c627 (0x404f8627)     (4973575)	Comments: press exit buttonthis happend
before  and is independant of the page visited.

I'll look for more current crashes on the MozillaTrunk as well.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 10

17 years ago
There are a few incidents with Netscape 6.22 and recent MozillaTrunk builds as
well.  Here is one of the recent Trunk crashes: 

Incident ID 5016486   
Stack Signature  nsSocketBS::GetTransport() 45067f95
Trigger Time 2002-04-09 16:03:00
Email Address
URL visited nope
Build ID 2002040410
Product ID MozillaTrunk
Platform
Operating System LinuxIntel
Module
Trigger Reason SIGSEGV: Segmentation Fault: (signal 11)
User Comments Had navigator open. Hit Ctrl-2 to open browser, then realised I
should be using the latest nightly. So I hit Ctrl-Q to quit Mozilla. After both
windows had closed, Talkback showed up.
Stack Trace
nsSocketBS::GetTransport()
nsSocketBS::ReleaseSocket()
nsSocketBOS::Write()
nsImapProtocol::TellThreadToDie()
nsImapIncomingServer::CloseCachedConnections()
nsMsgAccountManager::closeCachedConnections()
_hashEnumerate__FP11PLHashEntryiPv()
PL_HashTableEnumerateEntries()
nsHashtable::Enumerate()
nsMsgAccountManager::CloseCachedConnections()
nsMsgAccountManager::Shutdown()
nsMsgAccountManager::Observe()
nsObserverService::NotifyObservers()
NS_ShutdownXPCOM()
main()
libc.so.6 + 0x1917f (0x404b417f) 
Summary: M094 Trunk crash closing mail [@ nsSocketBS::GetTransport] → M099 N622 Trunk crash closing mail [@ nsSocketBS::GetTransport]
(Reporter)

Comment 11

17 years ago
Incindents for this one are still showing up in Linux on M1RC1. 

huang/mscott, can you repro this crash setting up an IMAP mail box with no 
trash? (See the first user comment below.)

M1RC1 (nsSocketBS::GetTransport):       11
 Unique Users  9
(5429572) - [Linux 2.4.3] (Build 2002041711): closing the mail reader;  had an 
imap error moving messages to trash mailbox (which does not exist)  
(5645829) - [Linux 2.4.9-13] (Build 2002041711): 3rd time URL: ??? closed 
mozilla & mail.. got the feedback agent
 
Summary: M099 N622 Trunk crash closing mail [@ nsSocketBS::GetTransport] → M1RC1 N622 Trunk crash closing mail [@ nsSocketBS::GetTransport]
(Reporter)

Comment 12

17 years ago
Dupe of 123097.

*** This bug has been marked as a duplicate of 123097 ***
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 13

17 years ago
Verified as dup.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
Crash Signature: [@ nsSocketBS::GetTransport]
You need to log in before you can comment on or make changes to this bug.