[Tarako] Reseting the phone or OTAing the phone will show the Android OS logo

RESOLVED FIXED

Status

Firefox OS
Vendcom
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: nhirata, Assigned: ying.xu)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:1.3T+, b2g-v1.3T fixed)

Details

(Whiteboard: [POVB])

Attachments

(4 attachments, 1 obsolete attachment)

1. either do a OTA or a phone reset

Expected: firefox OS logo or a non-Android logo
Actual: Android logo

Note:
Tarako 5/12 pac file was used.
James, can we get this changed please?
Flags: needinfo?(james.zhang)

Updated

3 years ago
Component: Gaia::System → Vendcom
Whiteboard: [POVB]
What can I do on my side, do you have any firefox recovery log to change?
Assignee: nobody → lianxiang.zhou
Flags: needinfo?(ttsai)
Flags: needinfo?(kli)
Flags: needinfo?(james.zhang)
blocking-b2g: --- → 1.3T?
status-b2g-v1.3T: --- → affected
James, I think this can be fixed simply by removing all these images file in recovery ROM.
bootable/recovery/res/images/icon_*.png
Flags: needinfo?(ttsai)
Flags: needinfo?(kli)
1.3T+, we need to remove android logo on firefox OS devices. thanks
blocking-b2g: 1.3T? → 1.3T+
(In reply to Kai-Zhen Li from comment #3)
> James, I think this can be fixed simply by removing all these images file in
> recovery ROM.
> bootable/recovery/res/images/icon_*.png

If no images, it shows black screen?
Lianxiang will take it, but I confirm we need recovery image for FirefoxOS.
Flags: needinfo?(nhirata.bugzilla)
Flags: needinfo?(lianxiang.zhou)
Flags: needinfo?(kli)

Comment 7

3 years ago
(In reply to James Zhang from comment #5)
> (In reply to Kai-Zhen Li from comment #3)
> > James, I think this can be fixed simply by removing all these images file in
> > recovery ROM.
> > bootable/recovery/res/images/icon_*.png
> 
> If no images, it shows black screen?

If no images, it shows black screen and causes recovery abort.

Finding update package...
I:Update location: /sdcard/update.zip
Opening update package...
I:1 key(s) loaded from /res/keys
Verifying update package...
I:verify_file returned 1
E:signature verification failed
Installation aborted.

We can fix the abort, but how to fix the black screen? Maybe we need some FFOS logo images to replace them.
Taking a step back talk, we can give text tips to display the recovery process. It's ok?
Flags: needinfo?(lianxiang.zhou)
James, I think you can replace them with a black image files or non-android logo image files.
Flags: needinfo?(kli)
(In reply to Zhou Lianxiang from comment #7)
> (In reply to James Zhang from comment #5)
> > (In reply to Kai-Zhen Li from comment #3)
> > > James, I think this can be fixed simply by removing all these images file in
> > > recovery ROM.
> > > bootable/recovery/res/images/icon_*.png
> > 
> > If no images, it shows black screen?
> 
> If no images, it shows black screen and causes recovery abort.
> 
> Finding update package...
> I:Update location: /sdcard/update.zip
> Opening update package...
> I:1 key(s) loaded from /res/keys
> Verifying update package...
> I:verify_file returned 1
> E:signature verification failed
> Installation aborted.
> 
> We can fix the abort, but how to fix the black screen? Maybe we need some
> FFOS logo images to replace them.
> Taking a step back talk, we can give text tips to display the recovery
> process. It's ok?

I think installation aborted is caused by "signature verification failed", it is quite clear from the above log. Need to make sure the keys is installed correctly in recovery ROM (recovery/root/res/keys).
1) Kai-Zhen, Wouldn't the signature key change if the image is deleted?  A new key needs to be generated for the change in the files, right?  Maybe I am misunderstanding things.

2) Pinging the ux team to see if they can either provide an image to reuse for recovery or have one created.
UX, this is the splash screen when you try to reset the phone or run a recovery and it is trying to show the progress of the reset.
Flags: needinfo?(firefoxos-ux-bugzilla)
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #10)
> 1) Kai-Zhen, Wouldn't the signature key change if the image is deleted?  A
> new key needs to be generated for the change in the files, right?  Maybe I
> am misunderstanding things.

Naoki, The keys used to generated update.zip should be the same as the one in recovery ROM. The keys file in recovery ROM can't be deleted or changed. I think this could be the keys file is missing in recovery ROM of PAC file. 

James, could you help to check if the key is installed correctly in recovery ROM of PAC file? Thanks!
Flags: needinfo?(james.zhang)

Comment 12

3 years ago
Flagging Peter to provide an image to use for recovery.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(pla)

Comment 13

3 years ago
Peter can't take this due to homescreen work (understandable). Ni? Patryk for reassignment.
Flags: needinfo?(pla) → needinfo?(padamczyk)
Ok, Thanks Khai-Zhen for the explanation.  It was my misunderstanding

Thanks Stephany!
Flags: needinfo?(nhirata.bugzilla)

Comment 15

3 years ago
I'll help provide the image. 

Naoki - could you please attached the (android) image currently being used (looking for a size reference)? If I could also get an contextual screenshot of what's currently in place, that would be awesome as well. 

Thanks!
H.
Flags: needinfo?(padamczyk) → needinfo?(nhirata.bugzilla)
Created attachment 8433505 [details]
images.zip

Attached are all the images that occur outside of being booted into the device for the Tarako that I am aware of.

ie images folder found in : ~/Projects/B2G_emulator/out/target/product/sp6821a_gonk/recovery/root/res/
Flags: needinfo?(nhirata.bugzilla)
Flags: needinfo?(hnguyen)

Comment 17

3 years ago
Thanks for the images Naoki. 

So just to confirm the order of the appearance after the OTA update: 

android splash screen > carrier splash screen > firefox animation (w/ the burning tail)

If this is the correct order then we will need a new set of images but if it isn't then we should be using the firefox animation.
Flags: needinfo?(hnguyen) → needinfo?(nhirata.bugzilla)
I am not sure where the carrier splash screen will fit.  Currently when I do a phone reset, this is what I see:
SPRD splash screen -> android splash screen ( recovery mode ) -> SPRD splash screen ( after reboot ) -> firefox animation boot screen -> firefox logo for gaia boot -> FTU
Flags: needinfo?(nhirata.bugzilla)
Flags: needinfo?(hnguyen)
(Assignee)

Comment 19

3 years ago
We should replace these images。

icon_error
icon_installing
icon_installing_overlay01-06
Who can give us image?
Ying will help to replace images.
Flags: needinfo?(james.zhang)
Assignee: lianxiang.zhou → ying.xu

Comment 21

3 years ago
I'm working on the images now. They should be available shortly.
Flags: needinfo?(hnguyen)

Comment 22

3 years ago
Created attachment 8434219 [details]
1017735_Assets_Spec.zip

Attaching images and spec. 

Please let me know if you have any questions. 

Thanks
Ying, can you help to replace with the images in comment 22? Thanks!
Flags: needinfo?(ying.xu)
(Assignee)

Comment 24

3 years ago
Created attachment 8434793 [details]
ota-display-notwell.JPG

(In reply to Hung Nguyen from comment #22)
> Created attachment 8434219 [details]
> 1017735_Assets_Spec.zip

H,Nguyen.

Can you adjust the width of these pictures icon_installing_overlay01-07
keep them the same with original width
The UI effect is not very well.
Please see the attachment

Comment 25

3 years ago
Created attachment 8434954 [details]
1017735_Assets_Spec_V02.zip

Updated the width. 

Ying can you send me a screenshot once you've implemented? 

Thanks
Hung
Attachment #8434219 - Attachment is obsolete: true
(Assignee)

Comment 26

3 years ago
(In reply to Kai-Zhen Li from comment #23)
> Ying, can you help to replace with the images in comment 22? Thanks!

Hi, kaizhen.
Because we have created some branch of 6821ffos very faulty before.
I'm sorry to tell you we git push -f the repo bootable/recovery in sprd git server again.
Please update the server on your side.
thank you very much.

-  <project path="bootable/recovery" name="platform/bootable/recovery" />
+  <project path="bootable/recovery" name="platform/bootable/recovery" revision="sprdb2g_gonk4.0_6821" />
Flags: needinfo?(kli)
Blocks: 1022454
It is updated in bug 1022454.
Flags: needinfo?(kli)
Fixed on my side, you just need change manifest, see bug 1022454.

commit 255d5880bcf2027d469b5b260759f923eb2b22fe
Author: ying.xu <ying.xu@spreadtrum.com>
Date:   Fri Jun 6 15:03:14 2014 +0800

    Bug#320452 replace image of recovery process with ffos sytle
    
    [self test   ]display ffos logo
    
    Change-Id: Iffe2e2432bae5e86417dc00962976be29e80c7c8
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-b2g-v1.3T: affected → fixed
Resolution: --- → FIXED
(Assignee)

Comment 29

3 years ago
(In reply to Hung Nguyen from comment #25)
> Created attachment 8434954 [details]
> 1017735_Assets_Spec_V02.zip
> 
> Updated the width. 
> 
> Ying can you send me a screenshot once you've implemented? 

when ota updating , I can't capture a screenshot by adb shell.
But I can take a phone using my phone. Is that ok for you?

Comment 30

3 years ago
Yes that works too. 

Thanks!
> Created attachment 8434954 [details]
> 1017735_Assets_Spec_V02.zip
> 

Sam, I think you'll also need this for dolphin and these images should be updated into "bootable/recovery/res/images/".
Flags: needinfo?(sam.hua)
(Assignee)

Comment 32

3 years ago
Created attachment 8437570 [details]
ota-update-normal.JPG

(In reply to Hung Nguyen from comment #25)
> Created attachment 8434954 [details]
> 1017735_Assets_Spec_V02.zip
> 
> Updated the width. 
> 
> Ying can you send me a screenshot once you've implemented? 

the new photo
(Assignee)

Updated

3 years ago
Flags: needinfo?(ying.xu)

Updated

3 years ago
Flags: needinfo?(sam.hua)
See Also: → bug 1079318
You need to log in before you can comment on or make changes to this bug.