JRE 1.4b2 plugin fails to load (undefined symbol)

RESOLVED DUPLICATE of bug 100904

Status

Core Graveyard
Java: OJI
--
critical
RESOLVED DUPLICATE of bug 100904
16 years ago
7 years ago

People

(Reporter: Reinout van Schouwen, Assigned: Joe Chou)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
platform: Mandrake 8.1rc1

This problem began when I upgraded to 0.9.4, everything was fine in 0.9.3. I
don't understand why I seem to be the only one having this problem?!

output on startup:

LoadPlugin: failed to initialize shared library
/usr/java/j2sdk1.4.0/jre/plugin/i386/ns610/libjavaplugin_oji140.so
[/usr/java/j2sdk1.4.0/jre/plugin/i386/ns610/libjavaplugin_oji140.so: undefined
symbol:
GetService__16nsServiceManagerRC4nsIDRC4nsIDPP11nsISupportsP19nsIShutdownListener]
The Java plugin is not listed in about:plugins .
(Reporter)

Comment 1

16 years ago
Reassigning because I read in other bugs that Joe Chou is the new owner of this
component.

Installing 0.9.5 on my Mandrake 8.1 box brings no solution: it segfaults
whenever theres a link to the java plugin present. Removing it solves the
problem >> critical.
Assignee: edburns → joe.chou
Severity: major → critical
(Reporter)

Comment 2

16 years ago
I fiddled a bit with gdb. Here's the output and the backtrace, I hope it's useful!

-- snip --

(gdb) run
Starting program: /usr/local/mozilla-0.9.5/./mozilla-bin 
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...[New Thread 1024 (
LWP 14128)]
Warning: MOZILLA_FIVE_HOME not set.
Warning: MOZILLA_FIVE_HOME not set.
[New Thread 2049 (LWP 14142)]
[New Thread 1026 (LWP 14143)]
[New Thread 2051 (LWP 14144)]
Message: gdkxft: bad app '/usr/local/mozilla-0.9.5/./mozilla-bin' - disabling gd
kxft
[New Thread 3076 (LWP 14146)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1024 (LWP 14128)]
0x4053d66e in malloc () from /lib/libc.so.6

-- snip --
(gdb) bt
#0  0x4053d66e in malloc () from /lib/libc.so.6
#1  0x4053ebce in calloc () from /lib/libc.so.6
#2  0x40142e3a in XPT_ArenaMalloc () from ./libxpcom.so
#3  0x40143dd9 in XPT_FillMethodDescriptor () from ./libxpcom.so
#4  0x40143aae in XPT_InterfaceDescriptorAddConsts () from ./libxpcom.so
#5  0x40143463 in XPT_DestroyInterfaceDirectoryEntry () from ./libxpcom.so
#6  0x401432f6 in XPT_DoHeader () from ./libxpcom.so
#7  0x4013ea41 in xptiInterfaceInfoManager::ReadXPTFile () from ./libxpcom.so
#8  0x4013eb65 in xptiInterfaceInfoManager::LoadFile () from ./libxpcom.so
#9  0x4013cde9 in xptiInterfaceInfo::ResolveLocked () from ./libxpcom.so
#10 0x4013cd52 in xptiInterfaceInfo::Resolve () from ./libxpcom.so
#11 0x4013d2c1 in xptiInterfaceInfo::GetConstantCount () from ./libxpcom.so
#12 0x40edec98 in NSGetModule ()
   from /usr/local/mozilla-0.9.5/components/libjsdom.so
#13 0x40edf04d in NSGetModule ()
   from /usr/local/mozilla-0.9.5/components/libjsdom.so
#14 0x40ee284d in NSGetModule ()
   from /usr/local/mozilla-0.9.5/components/libjsdom.so
#15 0x40ee382e in NSGetModule ()
   from /usr/local/mozilla-0.9.5/components/libjsdom.so
#16 0x40ede163 in NSGetModule ()
   from /usr/local/mozilla-0.9.5/components/libjsdom.so
#17 0x40e9d2aa in NSGetModule ()
---Type <return> to continue, or q <return> to quit---
   from /usr/local/mozilla-0.9.5/components/libdocshell.so
#18 0x40e9e50e in NSGetModule ()
   from /usr/local/mozilla-0.9.5/components/libdocshell.so
#19 0x4013a49d in nsGetInterface::operator() () from ./libxpcom.so
#20 0x40164a51 in nsCOMPtr_base::assign_from_helper () from ./libxpcom.so
#21 0x407d1671 in NSGetModule ()
   from /usr/local/mozilla-0.9.5/components/libnsappshell.so
#22 0x407d04b3 in NSGetModule ()
   from /usr/local/mozilla-0.9.5/components/libnsappshell.so
#23 0x407d0889 in NSGetModule ()
   from /usr/local/mozilla-0.9.5/components/libnsappshell.so
#24 0x0804ecbb in NS_CreateNativeAppSupport ()
#25 0x0804f6a5 in main ()
#26 0x404d95b0 in __libc_start_main () from /lib/libc.so.6

-- snip --


Comment 3

16 years ago
I can confirm this problem exists with both JDK 1.4.0beta2 and the just-released
1.4.0beta3. Build ID 2001103010 (and earlier as well). The platform is a SuSE
Linux 7.2/glibc 2.2.2.

Probably should be marked as NEW since the JDK 1.3.x Java plugins I've tried all
work (some require environment tweaks).

Comment 4

16 years ago
This is actually a duplicate of bug 100904

Comment 5

16 years ago
Other related bug is 96910
(Reporter)

Comment 6

16 years ago
manly, thanks for pointing out the dupe.

*** This bug has been marked as a duplicate of 100904 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 7

15 years ago
Chris Petersen is a new QA contact for oji component. His email is:
petersen@netscape.com
Assignee: joe.chou → petersen
fixing small error for pmac@netscape.com (filter with : SPAMMAILSUCKS)
Assignee: petersen → joe.chou
QA Contact: pmac → petersen

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.