Can't use "(", ")" or "|" in the other character field to create a table from selection

VERIFIED FIXED in mozilla0.9.6

Status

SeaMonkey
Composer
VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: TucsonTester2, Assigned: Charles Manske)

Tracking

Trunk
mozilla0.9.6

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

17 years ago
Build ID: 20010924

Reproducible: Always

Steps to reproduce:
1.Open Composer
2.Type in: Hello,hello
3.Click edit->select all
4.Click on the table button on the toolbar
5.Click on the other option and type in ( as the separator
6.Click ok

Actual Results:
The window will not close.  Instead what happens is that the window will be open
and not allow you to close it unless you cancel or choose another separator. 
This is different from every other separator.  If the separator is not in the
selection then it will just make a one cell table.  If you put a ( into the area
you select and then choose to create a table, the table will be made fine.

Expected Results:
I would expect that the ( would be treated like any other character separator.
(Reporter)

Comment 1

17 years ago
actually a ( does not work at all, it is the ) that only works when it is
included in the selection.  So the steps to reproduce should be:

Steps to reproduce:
1.Open Composer
2.Type in: Hello,hello
3.Click edit->select all
4.Click on the table button on the toolbar
5.Click on the other option and type in ) as the separator
6.Click ok

So once you add a ) to the selection the proper table will be created.

*Note*
The ( does not work at all. If you put it in as the character separator you will
not be able to close the window by clicking ok even if ( is included in the
selection.
Summary: Using a ( in the other character field while creating a table from selection does not work unless it is in the seleciton → Using a ) in the other character field while creating a table from selection does not work unless it is in the seleciton

Comment 2

17 years ago
-->cmanske
Assignee: syd → cmanske
(Assignee)

Comment 3

17 years ago
I don't think having the character "in the selection" is relevant.
The main problem is that "(" and ")" needs to be "escaped" to be used in the 
convert to table code.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → mozilla0.9.6
(Assignee)

Comment 4

17 years ago
Created attachment 52248 [details] [diff] [review]
Fix - add "(" and ")" to list of charaters the need "\" before them
(Assignee)

Updated

17 years ago
Keywords: patch, review
Summary: Using a ) in the other character field while creating a table from selection does not work unless it is in the seleciton → Using "(" or ")" in the other character field while creating a table from selection does not work correctly
Whiteboard: FIX IN HAND need r=,sr=
(Assignee)

Updated

17 years ago
Attachment #52248 - Attachment is obsolete: true
(Assignee)

Comment 5

17 years ago
Created attachment 52749 [details] [diff] [review]
Add "(", ")", and "|" to list of characters that must be preceeded with "\" to work correctly.
(Assignee)

Comment 6

17 years ago
*** Bug 101767 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

17 years ago
Summary: Using "(" or ")" in the other character field while creating a table from selection does not work correctly → Can't use "(", ")" or "|" in the other character field to create a table from selection

Comment 7

17 years ago
Comment on attachment 52749 [details] [diff] [review]
Add "(", ")", and "|" to list of characters that must be preceeded with "\" to work correctly.

sr=kin@netscape.com
Attachment #52749 - Flags: superreview+

Updated

17 years ago
Whiteboard: FIX IN HAND need r=,sr= → FIX IN HAND need r=

Comment 8

17 years ago
Comment on attachment 52749 [details] [diff] [review]
Add "(", ")", and "|" to list of characters that must be preceeded with "\" to work correctly.

r=timeless
Attachment #52749 - Flags: review+
(Assignee)

Comment 9

17 years ago
checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Keywords: patch, review
Resolution: --- → FIXED
Whiteboard: FIX IN HAND need r=

Comment 10

17 years ago
Verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.