if PSM not installed, https://foo should throw up an alert rather then do nothing

RESOLVED DUPLICATE of bug 47617

Status

()

Core
Networking
RESOLVED DUPLICATE of bug 47617
17 years ago
17 years ago

People

(Reporter: Jeremy M. Dolan, Assigned: neeti)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Mozilla is doing nothing when https: URLs are entered without PSM installed.
This makes the problem very non-obvious, and people are filing bugs about secure
pages mysteriously not loading (bug 87647, and I almost filed one before I
remembered I unchecked PSM today)

Can protocol handlers like https: and foo: be pluged in easily enough via an XPI
install, or does the core browser need intrinsic knowledge of what protocols
exsist? I ask because the correct UI reaction depends on whether https is
special or not.

*** This bug has been marked as a duplicate of 47617 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.