Permanent orange (elm): TEST-UNEXPECTED-FAIL | browser_parsable_css.js | loop/shared/css/common.css: Error in parsing value for 'padding'.

RESOLVED FIXED in mozilla33

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: standard8, Assigned: standard8)

Tracking

unspecified
mozilla33
Points:
---
Bug Flags:
qe-verify -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [p=0])

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
14:51:29  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/general/browser_parsable_css.js | Got error message for jar:file:///builds/slave/test/build/application/firefox/browser/omni.ja!/chrome/browser/content/browser/loop/shared/css/common.css: Error in parsing value for 'padding'.  Declaration dropped.
14:51:29     INFO -  Stack trace:
14:51:29     INFO -      JS frame :: chrome://mochitests/content/browser/browser/base/content/test/general/browser_parsable_css.js :: checkAllTheCSS/errorListener.observe :: line 167
14:51:29     INFO -      native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0
14:51:29     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/base/content/test/general/browser_parsable_css.js | Console message: [JavaScript Warning: "Error in parsing value for 'padding'.  Declaration dropped." {file: "jar:file:///builds/slave/test/build/application/firefox/browser/omni.ja!/chrome/browser/content/browser/loop/shared/css/common.css" line: 141 column: 11 source: "  padding: none;"}]
14:51:29  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/general/browser_parsable_css.js | All the styles (123) loaded without errors. - Got 1, expected 0
14:51:29     INFO -  Stack trace:
14:51:29     INFO -      JS frame :: chrome://mochikit/content/browser-test.js :: test_is :: line 752
14:51:29     INFO -      JS frame :: chrome://mochitests/content/browser/browser/base/content/test/general/browser_parsable_css.js :: checkAllTheCSS :: line 208
14:51:29     INFO -      JS frame :: resource://gre/modules/Task.jsm :: TaskImpl_run :: line 298
14:51:29     INFO -      JS frame :: resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js :: Handler.prototype.process :: line 863
14:51:29     INFO -      JS frame :: resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js :: this.PromiseWalker.walkerLoop :: line 742
14:51:29     INFO -      native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0
14:51:29     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/base/content/test/general/browser_parsable_css.js | Leaving test checkAllTheCSS
1
(Assignee)

Comment 1

4 years ago
Offending line:

https://hg.mozilla.org/projects/elm/annotate/69fbe0ab93ee/browser/components/loop/content/shared/css/common.css#l141

Should be '0' rather than 'none' according to:

https://developer.mozilla.org/en-US/docs/Web/CSS/padding

I can put a fix up in the morning.
Assignee: nobody → standard8
(Assignee)

Updated

4 years ago
Blocks: 974875
OS: Mac OS X → All
Hardware: x86 → All
Whiteboard: [p=0]
Target Milestone: --- → mozilla32
(Assignee)

Comment 2

4 years ago
Created attachment 8431503 [details] [diff] [review]
Remove unnecessary and incorrect padding value for notification close buttons

This removes the broken padding value. I tried setting a value of 0, but that broke the display, so removing it seems to make most sense.
Attachment #8431503 - Flags: review?(nperriault)
Comment on attachment 8431503 [details] [diff] [review]
Remove unnecessary and incorrect padding value for notification close buttons

LGTM
Attachment #8431503 - Flags: review?(nperriault) → review+
(Assignee)

Comment 4

4 years ago
Landed on Elm:

https://hg.mozilla.org/projects/elm/rev/7d10c2a28b58

Closing for tracking purposes
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Target Milestone: mozilla32 → mozilla33
(Assignee)

Updated

4 years ago
Duplicate of this bug: 996834
Untracking for QA. Please needinfo me to request specific testing.
Whiteboard: [p=0] → [p=0][qa-]
Flags: qe-verify-
Whiteboard: [p=0][qa-] → [p=0]
You need to log in before you can comment on or make changes to this bug.