sometimes images never get loaded until another scroll on imgur

RESOLVED INVALID

Status

Tech Evangelism Graveyard
English US
RESOLVED INVALID
4 years ago
3 years ago

People

(Reporter: BenWa, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8431280 [details]
Screenshot 2014-05-29 22.40.28.png

I'm going to guess this is a bug with the image visibility tracker.

I'm running on a retina MBP with firefox on a non retina screen if it's related to the problem.

STR:
1) Quick jump to parts of the gallery where images haven't started decoding.
2) Don't seen any scroll events
3) If image start decoding go back to 1)
4) Wait forever, images never start decoding.
(Reporter)

Comment 1

4 years ago
Switching tabs doesn't trigger the decoding. It's been several minutes and the images haven't decoded. Now I sent a single scroll wheel event and all the images downloaded and decoded within 1 second.
What's the website you are seeing this on?
(Reporter)

Comment 3

4 years ago
Opps, paste failed. It's https://imgur.com/a/Nic1H
Perfect, I can reproduce.
I don't think this is our image visibility code. If I reproduce the problem and then inspect the element where the image should be the only image to be found is:
  <img class="unloaded" data-src="//i.imgur.com/ksxURX1.png" alt="">
when I scroll and it becomes visible the src attribute then gets set properly and the unloaded class is removed. So either it's a bug in imgur or a bug in Gecko somewhere other than the image visibility. If it's a gecko bug then maybe we aren't sending the scroll events imgur is expecting? I can reproduce the problem in Firefox release (29), this leads me to suspect it's an imgur bug because if this was a gecko bug and it was in release I would expected to have seen more reports before this.
Summary: Visibility Tracker: Sometime images never start decoding. → sometimes images never get loaded until another scroll on imgur
(Reporter)

Updated

4 years ago
Assignee: nobody → english-us
Component: Layout → English US
Product: Core → Tech Evangelism
The "lazy loading" of images below the viewport is an approach several websites have started using. It has obvious performance benefits, and I don't think it makes sense to claim that this way of loading images is a bug in the site and that they should fix it. The obvious way to trigger loading images completely on scroll is - the scroll event. How do you "quick jump" without sending a scroll event, anyway?
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
The problem was that the images currently on the screen were never loaded.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Unless you tested and this is now fixed.
The description says 

> 1) Quick jump to parts of the gallery where images haven't started decoding.
> 2) Don't seen any scroll events

I may have misread this - I thought point 2 said "don't send any", but I'm still asking what you mean by "quick jump" :)

As a "Tech evangelism" issue, this reminds invalid. We have not identified any problem we want to reach out to websites and request a fix for. There is a potential core bug here if it's possible to "jump" to other scroll positions without firing scroll events - that sounds broken to me. In that case this bug should be moved to core.
Drag the scrollbar to some other part of the page is what I did. The bug reproduced in Chrome when I tried, so I very strongly doubt this is a bug in Firefox.
(Reporter)

Comment 11

4 years ago
It -could- be a problem with us not sending all the scroll events we should, but I think it's likely to be a problem with imgur. If we didn't send proper scrolling events then this would likely be a more common bug.
I can reproduce in Firefox, Safari and Chrome. I agree with Benoit, I think this is a TE bug with imgur but should be moved to Webcompat.com as it's not Firefox specific.

Bug opened here: https://github.com/webcompat/web-bugs/issues/123
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.