Closed Bug 1017962 Opened 8 years ago Closed 7 years ago

Decouple the control of screen backlight and button/keyboard backlight at Gaia

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.5+, b2g-master fixed)

RESOLVED FIXED
FxOS-S1 (26Jun)
blocking-b2g 2.5+
Tracking Status
b2g-master --- fixed

People

(Reporter: selin, Assigned: dwi2)

References

Details

Attachments

(1 file)

46 bytes, text/x-github-pull-request
timdream
: review+
Details | Review
In bug 911242, we've decoupled the control of button/keyboard backlight from screen backlight in MozPowerManager. So they are no longer controlled in align with each other. A follow-up fix may be necessary at Gaia to better cover the changes.
After discussing with Tim, in this bug we may still let backlight dis/enabling of screen couple to button/keyboard on the gaia side. This is in order to unblock the landing of gecko patch.

Then involing UX design to finish complete gaia work.
Blocks: 1172345
Evelyn, landing of bug 911242 without Gaia part here have unfortunately caused regression. Anyone in your team can take over the work from Sean? If not I will ask my team to take this.
Flags: needinfo?(ehung)
Next release would need this or we would have to backout the Gecko part first.
blocking-b2g: --- → 3.0+
Without any fancy UX, the Gaia patch is actually pretty trivial, given the WebIDL described here:

https://hg.mozilla.org/mozilla-central/diff/3dd59dda51fc/dom/webidl/MozPowerManager.webidl
Assignee: nobody → tzhuang
Flags: needinfo?(ehung)
To give the reason for splitting the backlight of screen and keypad:
  Referring to the experience from Helix project, the partner already modified this idea into their local branch. Partner would like to reduce the power consumption from disabling the keypad backlight in a short period not following the screen backlight. From their UX point of view, the keypad backlight is no necessary to keep that longer as screen's.

From eng point of view, to extend the flexibility of platform capability is our goal then Gaia can follow the different UX to design the relationship between screen and keypad's backlight.

If UX doesn't have any opinion then the easy way is to enable/disable screen and keypad's backlight in the same timing. If partner has different thought then they can still customize easily because web api is there already.
Status: NEW → ASSIGNED
Attached file pull request
I made a patch to synchronize key backlight behavior with screen. Partner could always customize this by removing the patch and doing their own customization.

Hi Tim,
Could you help to review the patch? Thanks
Attachment #8622342 - Flags: review?(timdream)
Comment on attachment 8622342 [details] [review]
pull request

Woot and thanks!
Attachment #8622342 - Flags: review?(timdream) → review+
Hello,

Is it possible to also apply this patch on 2.2 and 2.1 branches ?
Target Milestone: --- → FxOS-S1 (26Jun)
You need to log in before you can comment on or make changes to this bug.