[Flame][V1.4][Dialer]Call log is still displayed with name and photo, user can tap it to view the contact's details after user delete this contact.

RESOLVED INVALID

Status

Firefox OS
Gaia::Dialer
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: panda67231, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: bamboo)

Attachments

(1 attachment)

9.80 MB, application/x-rar
Details
(Reporter)

Description

4 years ago
Created attachment 8431448 [details]
Attachment.rar

[1.Description]:
Call log is still displayed with name and photo, user can tap it to view the contact's details after user delete this contact. In the contact's details view, user can enter the contact edit view and tap the delete button every time. 

Attach the video: video_Delete.mp4
Attach the logs: bugreport_Delete.txt & logcat_Delete.txt

Happened time: 11:06 AM

[2.Testing Steps]: 
Precondition: a. There is at least one call log in Today; b. There is at least one call log from contact with photo in Yesterday.
1. Open Call log.
2. Tap a call log from one contact with photo under "YESTERDAY".
**It will enter into the contact details view.
3. Delete this contact.
**It will not be displayed in Address book.
4. Back to Call log view.


[3.Expected Result]: 
This call log should not be displayed with name and photo.

[4.Actual Result]: 
This call log is still displayed with name and photo, user can tap it to view the contact's details.

[5.Reproduction build]: 
Gaia        7709936aeb21859d1607dbd038489493803bb085
Gecko     https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/5bf038fae0f1
BuildID    20140522160202
Version    30.0

[6.Reproduction Frequency]: Always Recurrence
This is invalid now because we redesigned the call log to exclude contact photos in bug 1045499.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.