Mail highlighter skips to bottom after deleting more than one mail item at the same time

RESOLVED WORKSFORME

Status

MailNews Core
Networking: IMAP
--
enhancement
RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: nabelek, Assigned: Scott MacGregor)

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.4+) Gecko/20010926
BuildID:    2001092608

Mail highlighter skips all the way to the bottom of the mail list when more than
one mail item in IMAP mail listing is deleted at the same time. If one deletes
only one mail item, the highliter moves correctly to the next mail, however, if
more than one item is deleted, the highliter skips to the bottom of the list.

Reproducible: Always
Steps to Reproduce:
1. Dislay IMAP mail list
2. Highlight more than one item for deletion.
3. Press delete


Actual Results:  4. The highliter jumps the the bottom of the entire list.

Expected Results:  5. The highliter should move to the next mail item after the
deleted items or not move at all (Netscape 4.7 behaviour).

Comment 1

17 years ago
this is a problem in w2k also.

Comment 2

17 years ago
FWIW, WFM using Mac/2001091311 (0.9.4).

Comment 3

17 years ago
Also WFM using Mac/2001092813. Reporter, what is the Sort setting of the folder in 
question?

Comment 4

17 years ago
Reporter, can you still reproduce this using 0.9.5?
(Reporter)

Comment 5

17 years ago
0.9.5 did not fix the problem. The problem occurs regardless of 
the sort: I tried Date, Subject and Sender. The problem occurs in 
each case.
(Reporter)

Comment 6

17 years ago
It seems to me that the problem can be easily solved by implementing Netscape 4.7 
behavior. In Netscape 4.7 the highlighter is simply turned off after items are 
selected and marked for deletion. In my opinion, turning off the highlighter is 
more intuitive after the deleted items are marked than repositioning the 
highlighter to some other mail item (especially when the highlighter skips to the 
bottom of the mail stack; the current Mozilla behavior).

Comment 7

17 years ago
nabelek, that makes sense to me. I recommend you transform this bug into just such an 
RFE.
(Reporter)

Updated

17 years ago
Severity: normal → enhancement

Comment 8

17 years ago
nabelek, please address my Additional Comment #7 on this bug. Also, please retest using 
0.9.6 now that it's out.
(Reporter)

Comment 9

17 years ago
Greg. The problem still persits as of 0.9.6.
I transformed this bug to an enhancement (see
http://bugzilla.mozilla.org/show_bug.cgi?id=101810) some time ago. If there is
more that needs to be done, please, do it for me. Thanks.
nabelek, can you reproduce it in 1.0RC1? If not, mark the bug as "worksforme"

Comment 11

16 years ago
More than one month without response.

pi
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Updated

16 years ago
QA Contact: huang → gchan
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.